diff mbox series

[1/2] gpio: provide for_each_gpio()

Message ID 20240215083328.11464-1-brgl@bgdev.pl
State New
Headers show
Series [1/2] gpio: provide for_each_gpio() | expand

Commit Message

Bartosz Golaszewski Feb. 15, 2024, 8:33 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

We only provide iterators for requested GPIOs to provider drivers. In
order to allow them to display debug information about all GPIOs, let's
provide a variant for iterating over all GPIOs.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 include/linux/gpio/driver.h | 15 +++++++++++++++
 1 file changed, 15 insertions(+)

Comments

Linus Walleij Feb. 21, 2024, 9:51 p.m. UTC | #1
Hi Bartosz,

On Thu, Feb 15, 2024 at 9:33 AM Bartosz Golaszewski <brgl@bgdev.pl> wrote:

> From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
>
> We only provide iterators for requested GPIOs to provider drivers. In
> order to allow them to display debug information about all GPIOs, let's
> provide a variant for iterating over all GPIOs.
>
> Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
(...)

> +/**
> + * for_each_gpio - Iterates over all GPIOs for given chip.

Does this really intuitively fit with other functions named for_each_XXX()?

> + * @_chip: Chip to iterate over.
> + * @_i: Loop counter.
> + * @_label: Place to store the address of the label if the GPIO is requested.
> + *          Set to NULL for unused GPIOs.
> + */
> +#define for_each_gpio(_chip, _i, _label) \
> +       for (CLASS(_gpiochip_for_each_data, _data)(&_label, &_i); \
> +            *_data.i < _chip->ngpio; \
> +            (*_data.i)++, kfree(*(_data.label)), *_data.label = NULL) \
> +               if (IS_ERR(*_data.label = \
> +                       gpiochip_dup_line_label(_chip, *_data.i))) {} \
> +               else

I would call it for_each_line_label() or something. I try to avoid using
"gpio" in function names as well because of ambiguity, I could also go
with for_each_hwgpio_label() I suppose.

With some more reasonable name:
Reviewed-by: Linus Walleij <linus.walleij@linaro.org>

Yours,
Linus Walleij
Bartosz Golaszewski Feb. 22, 2024, 8:48 a.m. UTC | #2
On Wed, Feb 21, 2024 at 10:51 PM Linus Walleij <linus.walleij@linaro.org> wrote:
>
> Hi Bartosz,
>
> On Thu, Feb 15, 2024 at 9:33 AM Bartosz Golaszewski <brgl@bgdev.pl> wrote:
>
> > From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> >
> > We only provide iterators for requested GPIOs to provider drivers. In
> > order to allow them to display debug information about all GPIOs, let's
> > provide a variant for iterating over all GPIOs.
> >
> > Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> (...)
>
> > +/**
> > + * for_each_gpio - Iterates over all GPIOs for given chip.
>
> Does this really intuitively fit with other functions named for_each_XXX()?
>
> > + * @_chip: Chip to iterate over.
> > + * @_i: Loop counter.
> > + * @_label: Place to store the address of the label if the GPIO is requested.
> > + *          Set to NULL for unused GPIOs.
> > + */
> > +#define for_each_gpio(_chip, _i, _label) \
> > +       for (CLASS(_gpiochip_for_each_data, _data)(&_label, &_i); \
> > +            *_data.i < _chip->ngpio; \
> > +            (*_data.i)++, kfree(*(_data.label)), *_data.label = NULL) \
> > +               if (IS_ERR(*_data.label = \
> > +                       gpiochip_dup_line_label(_chip, *_data.i))) {} \
> > +               else
>
> I would call it for_each_line_label() or something. I try to avoid using
> "gpio" in function names as well because of ambiguity, I could also go
> with for_each_hwgpio_label() I suppose.

The problem is: this doesn't iterate over labels. It really goes
through all offsets and if there's no consumer then the label is NULL
(I should have said that in the kerneldoc).

>
> With some more reasonable name:

Does for_each_hwgpio() make more sense?

Bart

> Reviewed-by: Linus Walleij <linus.walleij@linaro.org>
>
> Yours,
> Linus Walleij
Linus Walleij Feb. 22, 2024, 9:18 a.m. UTC | #3
On Thu, Feb 22, 2024 at 9:48 AM Bartosz Golaszewski <brgl@bgdev.pl> wrote:
> On Wed, Feb 21, 2024 at 10:51 PM Linus Walleij <linus.walleij@linaro.org> wrote:
> >
> > Hi Bartosz,
> >
> > On Thu, Feb 15, 2024 at 9:33 AM Bartosz Golaszewski <brgl@bgdev.pl> wrote:
> >
> > > From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> > >
> > > We only provide iterators for requested GPIOs to provider drivers. In
> > > order to allow them to display debug information about all GPIOs, let's
> > > provide a variant for iterating over all GPIOs.
> > >
> > > Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> > (...)
> >
> > > +/**
> > > + * for_each_gpio - Iterates over all GPIOs for given chip.
> >
> > Does this really intuitively fit with other functions named for_each_XXX()?
> >
> > > + * @_chip: Chip to iterate over.
> > > + * @_i: Loop counter.
> > > + * @_label: Place to store the address of the label if the GPIO is requested.
> > > + *          Set to NULL for unused GPIOs.
> > > + */
> > > +#define for_each_gpio(_chip, _i, _label) \
> > > +       for (CLASS(_gpiochip_for_each_data, _data)(&_label, &_i); \
> > > +            *_data.i < _chip->ngpio; \
> > > +            (*_data.i)++, kfree(*(_data.label)), *_data.label = NULL) \
> > > +               if (IS_ERR(*_data.label = \
> > > +                       gpiochip_dup_line_label(_chip, *_data.i))) {} \
> > > +               else
> >
> > I would call it for_each_line_label() or something. I try to avoid using
> > "gpio" in function names as well because of ambiguity, I could also go
> > with for_each_hwgpio_label() I suppose.
>
> The problem is: this doesn't iterate over labels. It really goes
> through all offsets and if there's no consumer then the label is NULL
> (I should have said that in the kerneldoc).
>
> >
> > With some more reasonable name:
>
> Does for_each_hwgpio() make more sense?

It's better it reflects the usage, but isn't the usage to conditionally
extract the label (or NULL) for each hwgpio?

What I'm after is if there is a risk that someone think this is a generic
iterator for hwgpios which would be confusing.

At the same time
for_each_hwgpio_attempt_extract_label() is a bit long I guess.

I don't wanna bikeshed too much so go with for_each_hwgpio() if
you don't immediately see anything better.

Yours,
Linus Walleij
diff mbox series

Patch

diff --git a/include/linux/gpio/driver.h b/include/linux/gpio/driver.h
index 9d0023f83a57..5f915b653548 100644
--- a/include/linux/gpio/driver.h
+++ b/include/linux/gpio/driver.h
@@ -551,6 +551,21 @@  DEFINE_CLASS(_gpiochip_for_each_data,
 	     }),
 	     const char **label, int *i)
 
+/**
+ * for_each_gpio - Iterates over all GPIOs for given chip.
+ * @_chip: Chip to iterate over.
+ * @_i: Loop counter.
+ * @_label: Place to store the address of the label if the GPIO is requested.
+ *          Set to NULL for unused GPIOs.
+ */
+#define for_each_gpio(_chip, _i, _label) \
+	for (CLASS(_gpiochip_for_each_data, _data)(&_label, &_i); \
+	     *_data.i < _chip->ngpio; \
+	     (*_data.i)++, kfree(*(_data.label)), *_data.label = NULL) \
+		if (IS_ERR(*_data.label = \
+			gpiochip_dup_line_label(_chip, *_data.i))) {} \
+		else
+
 /**
  * for_each_requested_gpio_in_range - iterates over requested GPIOs in a given range
  * @_chip:	the chip to query