mbox series

[v2,0/3] Use new GPIO direction defines for intel pinctrl

Message ID cover.1576132131.git.matti.vaittinen@fi.rohmeurope.com
Headers show
Series Use new GPIO direction defines for intel pinctrl | expand

Message

Matti Vaittinen Dec. 12, 2019, 6:33 a.m. UTC
We added definitions for GPIO line directions here:
https://git.kernel.org/pub/scm/linux/kernel/git/linusw/linux-gpio.git/commit/?id=9208b1e77d6e8e9776f34f46ef4079ecac9c3c25

Let's use them on Intel pincontrollers too.

Changes for v2:
  - Replaced ternary operator with if() for better readability

---

Matti Vaittinen (3):
  pinctrl: pinctrl-intel: Use GPIO direction definitions
  pinctrl: pinctrl-cherryview: Use GPIO direction definitions
  pinctrl: pinctrl-baytrail: Use GPIO direction definitions

 drivers/pinctrl/intel/pinctrl-baytrail.c   | 4 ++--
 drivers/pinctrl/intel/pinctrl-cherryview.c | 5 ++++-
 drivers/pinctrl/intel/pinctrl-intel.c      | 5 ++++-
 3 files changed, 10 insertions(+), 4 deletions(-)


base-commit: e42617b825f8 ("Linux 5.5-rc1")

Comments

Mika Westerberg Dec. 12, 2019, 11:21 a.m. UTC | #1
On Thu, Dec 12, 2019 at 08:33:54AM +0200, Matti Vaittinen wrote:
> We added definitions for GPIO line directions here:
> https://git.kernel.org/pub/scm/linux/kernel/git/linusw/linux-gpio.git/commit/?id=9208b1e77d6e8e9776f34f46ef4079ecac9c3c25
> 
> Let's use them on Intel pincontrollers too.
> 
> Changes for v2:
>   - Replaced ternary operator with if() for better readability
> 
> ---
> 
> Matti Vaittinen (3):
>   pinctrl: pinctrl-intel: Use GPIO direction definitions
>   pinctrl: pinctrl-cherryview: Use GPIO direction definitions
>   pinctrl: pinctrl-baytrail: Use GPIO direction definitions

Andy, please pick these up with my,

Acked-by: Mika Westerberg <mika.westerberg@linux.intel.com>
Andy Shevchenko Dec. 12, 2019, 1:29 p.m. UTC | #2
On Thu, Dec 12, 2019 at 01:21:35PM +0200, Mika Westerberg wrote:
> On Thu, Dec 12, 2019 at 08:33:54AM +0200, Matti Vaittinen wrote:
> > We added definitions for GPIO line directions here:
> > https://git.kernel.org/pub/scm/linux/kernel/git/linusw/linux-gpio.git/commit/?id=9208b1e77d6e8e9776f34f46ef4079ecac9c3c25
> > 
> > Let's use them on Intel pincontrollers too.
> > 
> > Changes for v2:
> >   - Replaced ternary operator with if() for better readability
> > 
> > ---
> > 
> > Matti Vaittinen (3):
> >   pinctrl: pinctrl-intel: Use GPIO direction definitions
> >   pinctrl: pinctrl-cherryview: Use GPIO direction definitions
> >   pinctrl: pinctrl-baytrail: Use GPIO direction definitions
> 
> Andy, please pick these up with my,
> 
> Acked-by: Mika Westerberg <mika.westerberg@linux.intel.com>

Pushed to my review and testing queue, thanks!