mbox series

[libgpiod,v2,0/7] treewide: remove more cruft and add some improvements

Message ID 20210115103018.27704-1-brgl@bgdev.pl
Headers show
Series treewide: remove more cruft and add some improvements | expand

Message

Bartosz Golaszewski Jan. 15, 2021, 10:30 a.m. UTC
From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

This is another batch of improvements to libgpiod before we overhaul the
data structure model.

The last patch adds the kernel uapi header to the repository so that we
no longer depend on its presence on the host system.

v1 -> v2:
- rename BIAS_NONE to BIAS_UNKNOWN
- rename DRIVE_NONE to DRIVE_PUSH_PULL
- rename BIAS_DISABLE to BIAS_DISABLED

Bartosz Golaszewski (7):
  treewide: remove helpers for opening chips by name & number
  treewide: simplify the active-low line property
  treewide: rename BIAS_AS_IS to BIAS_UNKNOWN
  treewide: rename BIAS_DISABLE to BIAS_DISABLED
  treewide: make drive settings an enum
  bindings: cxx: line: reorder bias mapping entries
  core: add the kernel uapi header to the repository

 bindings/cxx/chip.cpp                  |  41 +-
 bindings/cxx/examples/gpioinfocxx.cpp  |   3 +-
 bindings/cxx/gpiod.hpp                 |  61 +--
 bindings/cxx/line.cpp                  |  28 +-
 bindings/cxx/line_bulk.cpp             |   4 +-
 bindings/cxx/tests/tests-chip.cpp      |  97 +----
 bindings/cxx/tests/tests-event.cpp     |  14 +-
 bindings/cxx/tests/tests-iter.cpp      |   2 +-
 bindings/cxx/tests/tests-line.cpp      |  97 ++---
 bindings/python/examples/gpioinfo.py   |   4 +-
 bindings/python/gpiodmodule.c          | 187 +++------
 bindings/python/tests/gpiod_py_test.py | 177 ++++-----
 configure.ac                           |  12 +-
 include/gpiod.h                        |  69 +---
 lib/Makefile.am                        |   2 +-
 lib/core.c                             |  35 +-
 lib/helpers.c                          |  57 ---
 lib/uapi/gpio.h                        | 522 +++++++++++++++++++++++++
 tests/tests-chip.c                     |  41 --
 tests/tests-event.c                    |   2 +-
 tests/tests-line.c                     | 110 +++---
 tools/gpiodetect.c                     |   2 +-
 tools/gpiofind.c                       |   2 +-
 tools/gpioget.c                        |   2 +-
 tools/gpioinfo.c                       |  30 +-
 tools/gpiomon.c                        |   2 +-
 tools/gpioset.c                        |   2 +-
 tools/tools-common.c                   |  59 ++-
 tools/tools-common.h                   |   3 +
 29 files changed, 934 insertions(+), 733 deletions(-)
 create mode 100644 lib/uapi/gpio.h

Comments

Kent Gibson Jan. 18, 2021, 1:01 a.m. UTC | #1
On Fri, Jan 15, 2021 at 11:30:11AM +0100, Bartosz Golaszewski wrote:
> From: Bartosz Golaszewski <bgolaszewski@baylibre.com>
> 
> This is another batch of improvements to libgpiod before we overhaul the
> data structure model.
> 
> The last patch adds the kernel uapi header to the repository so that we
> no longer depend on its presence on the host system.
> 

+1 for this set, other than my specific comments.
I'm all for a small core C library.
And there are more drastic changes to come, so any problems missed
here can be picked up there.

Cheers,
Kent.