mbox series

[00/17] gpiolib: cdev: pre-uAPI v2 cleanups

Message ID 20200708041600.768775-1-warthog618@gmail.com
Headers show
Series gpiolib: cdev: pre-uAPI v2 cleanups | expand

Message

Kent Gibson July 8, 2020, 4:15 a.m. UTC
This collection of patches provides improvements to or
address minor problems in gpiolib-cdev.

The majority of the patches (1-7, 9-11) have been pulled directly from
my "gpio: cdev: add uAPI V2" patch set, as they are not related to any
uAPI changes.
The remaining patches were either split out of the remaining patches
from that set, as they are not directly part of the uAPI changes, or
were inspired by fixes for issues in that set, or were only noticed
subsequent to that set.

Changes since "gpio: cdev: add uAPI V2":
 - rebase onto latest gpio/devel
 - fix typo in patch 1 commit description
 - replace patch 8 with the blocking notifier call chain patch
 - rename priv to cdev instead of gcdev in patch 9
 - fix error handling in patch 10
 - add patches 12 to 17

Kent Gibson (17):
  gpiolib: move gpiolib-sysfs function declarations into their own
    header
  gpiolib: cdev: sort includes
  gpiolib: cdev: minor indentation fixes
  gpiolib: cdev: refactor gpiohandle_flags_to_desc_flags
  gpiolib: cdev: rename 'filep' and 'filp' to 'file' to be consistent
    with other use
  gpiolib: cdev: rename numdescs to num_descs
  gpiolib: cdev: remove pointless decrement of i
  gpiolib: cdev: use blocking notifier call chain instead of atomic
  gpiolib: cdev: rename priv to cdev
  gpiolib: cdev: fix minor race in GET_LINEINFO_WATCH
  gpiolib: cdev: remove recalculation of offset
  gpiolib: cdev: refactor linehandle cleanup into linehandle_free
  gpiolib: cdev: refactor lineevent cleanup into lineevent_free
  gpio: uapi: fix misplaced comment line
  tools: gpio: fix spurious close warning in lsgpio
  tools: gpio: fix spurious close warning in gpio-utils
  tools: gpio: fix spurious close warning in gpio-event-mon

 drivers/gpio/gpiolib-cdev.c  | 385 ++++++++++++++++-------------------
 drivers/gpio/gpiolib-sysfs.c |   1 +
 drivers/gpio/gpiolib-sysfs.h |  24 +++
 drivers/gpio/gpiolib.c       |  15 +-
 drivers/gpio/gpiolib.h       |  20 +-
 include/uapi/linux/gpio.h    |   2 +-
 tools/gpio/gpio-event-mon.c  |   3 +-
 tools/gpio/gpio-utils.c      |   4 +-
 tools/gpio/lsgpio.c          |   3 +-
 9 files changed, 217 insertions(+), 240 deletions(-)
 create mode 100644 drivers/gpio/gpiolib-sysfs.h


base-commit: b239e4454e59bc85d466eb5630da46f6a876df77

Comments

Bartosz Golaszewski July 9, 2020, 1:19 p.m. UTC | #1
On Wed, Jul 8, 2020 at 6:18 AM Kent Gibson <warthog618@gmail.com> wrote:
>
> This collection of patches provides improvements to or
> address minor problems in gpiolib-cdev.
>
> The majority of the patches (1-7, 9-11) have been pulled directly from
> my "gpio: cdev: add uAPI V2" patch set, as they are not related to any
> uAPI changes.
> The remaining patches were either split out of the remaining patches
> from that set, as they are not directly part of the uAPI changes, or
> were inspired by fixes for issues in that set, or were only noticed
> subsequent to that set.
>
> Changes since "gpio: cdev: add uAPI V2":
>  - rebase onto latest gpio/devel
>  - fix typo in patch 1 commit description
>  - replace patch 8 with the blocking notifier call chain patch
>  - rename priv to cdev instead of gcdev in patch 9
>  - fix error handling in patch 10
>  - add patches 12 to 17
>
> Kent Gibson (17):
>   gpiolib: move gpiolib-sysfs function declarations into their own
>     header
>   gpiolib: cdev: sort includes
>   gpiolib: cdev: minor indentation fixes
>   gpiolib: cdev: refactor gpiohandle_flags_to_desc_flags
>   gpiolib: cdev: rename 'filep' and 'filp' to 'file' to be consistent
>     with other use
>   gpiolib: cdev: rename numdescs to num_descs
>   gpiolib: cdev: remove pointless decrement of i
>   gpiolib: cdev: use blocking notifier call chain instead of atomic
>   gpiolib: cdev: rename priv to cdev
>   gpiolib: cdev: fix minor race in GET_LINEINFO_WATCH
>   gpiolib: cdev: remove recalculation of offset
>   gpiolib: cdev: refactor linehandle cleanup into linehandle_free
>   gpiolib: cdev: refactor lineevent cleanup into lineevent_free
>   gpio: uapi: fix misplaced comment line
>   tools: gpio: fix spurious close warning in lsgpio
>   tools: gpio: fix spurious close warning in gpio-utils
>   tools: gpio: fix spurious close warning in gpio-event-mon
>
>  drivers/gpio/gpiolib-cdev.c  | 385 ++++++++++++++++-------------------
>  drivers/gpio/gpiolib-sysfs.c |   1 +
>  drivers/gpio/gpiolib-sysfs.h |  24 +++
>  drivers/gpio/gpiolib.c       |  15 +-
>  drivers/gpio/gpiolib.h       |  20 +-
>  include/uapi/linux/gpio.h    |   2 +-
>  tools/gpio/gpio-event-mon.c  |   3 +-
>  tools/gpio/gpio-utils.c      |   4 +-
>  tools/gpio/lsgpio.c          |   3 +-
>  9 files changed, 217 insertions(+), 240 deletions(-)
>  create mode 100644 drivers/gpio/gpiolib-sysfs.h
>
>
> base-commit: b239e4454e59bc85d466eb5630da46f6a876df77
> --
> 2.27.0
>

Hi Kent,

The entire series looks good to me, thanks for doing this. I'll pick
it up into my tree and send a PR to Linus.

Bartosz