diff mbox series

[2/2] ext4: rename temporary variables in ext4_finish_bio()

Message ID 20220518120137.2544-2-liupeibao@163.com
State Rejected
Headers show
Series [1/2] ext4: page-io: use 'unsigned int' to bare use of 'unsigned' | expand

Commit Message

Liu Peibao May 18, 2022, 12:01 p.m. UTC
The temporary variable bio_start and bio_end are confusingly
misnamed. Rename them with bvec_ instead of bio_ to indicate
what they really are.

Signed-off-by: Liu Peibao <liupeibao@163.com>
---
 fs/ext4/page-io.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/fs/ext4/page-io.c b/fs/ext4/page-io.c
index fd55e11c8391..dd0a7f734d7f 100644
--- a/fs/ext4/page-io.c
+++ b/fs/ext4/page-io.c
@@ -106,8 +106,8 @@  static void ext4_finish_bio(struct bio *bio)
 		struct page *page = bvec->bv_page;
 		struct page *bounce_page = NULL;
 		struct buffer_head *bh, *head;
-		unsigned int bio_start = bvec->bv_offset;
-		unsigned int bio_end = bio_start + bvec->bv_len;
+		unsigned int bvec_start = bvec->bv_offset;
+		unsigned int bvec_end = bvec_start + bvec->bv_len;
 		unsigned int under_io = 0;
 		unsigned long flags;
 
@@ -127,8 +127,8 @@  static void ext4_finish_bio(struct bio *bio)
 		 */
 		spin_lock_irqsave(&head->b_uptodate_lock, flags);
 		do {
-			if (bh_offset(bh) < bio_start ||
-			    bh_offset(bh) + bh->b_size > bio_end) {
+			if (bh_offset(bh) < bvec_start ||
+			    bh_offset(bh) + bh->b_size > bvec_end) {
 				if (buffer_async_write(bh))
 					under_io++;
 				continue;