diff mbox series

PATCH] x86: Rename readelflib.c

Message ID CAMe9rOriNzF+nQdp5yrGxpoiJ7tWe+hn8LHNf9TP-AnSLmYD8A@mail.gmail.com
State New
Headers show
Series PATCH] x86: Rename readelflib.c | expand

Commit Message

H.J. Lu Dec. 5, 2020, 3:15 p.m. UTC
On Fri, Dec 4, 2020 at 1:15 PM H.J. Lu <hjl.tools@gmail.com> wrote:
>
> On Fri, Dec 4, 2020 at 1:13 PM H.J. Lu <hjl.tools@gmail.com> wrote:
> >
> > On Fri, Dec 4, 2020 at 1:05 PM Florian Weimer <fw@deneb.enyo.de> wrote:
> > >
> > > * H. J. Lu via Libc-alpha:
> > >
> > > > Rename linux/i386/readelflib.c to linux/x86/readelflib.c and remove
> > > > x86_64/readelflib.c.  Also remove EM_IA_64 support from i386 ldconfig.
> > >
> > > I'm curious—what's the context for this change?
> >
> > It is a cleanup job while working on x86-64 ISA level support to ldconfig.
> >
> > > Do the remaining ia64 systems use an ia64 ldconfig?  (The latest CPUs
> > > no longer support i386 IIRC.)
> >
> > There is a separate, unrelated linux/ia64/readelflib.c.
>
> With this patch, you can no longer run i386 ldconfig on ia64.   I am not
> even sure if it works today.
>

Here is the patch just to rename.  I have a followup patch for ldconfig
to add ISA level check to glibc-hwcaps

Comments

Florian Weimer Dec. 6, 2020, 2:09 p.m. UTC | #1
* H. J. Lu:

> On Fri, Dec 4, 2020 at 1:15 PM H.J. Lu <hjl.tools@gmail.com> wrote:
>>
>> On Fri, Dec 4, 2020 at 1:13 PM H.J. Lu <hjl.tools@gmail.com> wrote:
>> >
>> > On Fri, Dec 4, 2020 at 1:05 PM Florian Weimer <fw@deneb.enyo.de> wrote:
>> > >
>> > > * H. J. Lu via Libc-alpha:
>> > >
>> > > > Rename linux/i386/readelflib.c to linux/x86/readelflib.c and remove
>> > > > x86_64/readelflib.c.  Also remove EM_IA_64 support from i386 ldconfig.
>> > >
>> > > I'm curious—what's the context for this change?
>> >
>> > It is a cleanup job while working on x86-64 ISA level support to ldconfig.
>> >
>> > > Do the remaining ia64 systems use an ia64 ldconfig?  (The latest CPUs
>> > > no longer support i386 IIRC.)
>> >
>> > There is a separate, unrelated linux/ia64/readelflib.c.
>>
>> With this patch, you can no longer run i386 ldconfig on ia64.   I am not
>> even sure if it works today.
>>
>
> Here is the patch just to rename.  I have a followup patch for ldconfig
> to add ISA level check to glibc-hwcaps

I think this is okay.  It would also make sense to process EM_IA_64
unconditionally in support of qemu-user.
H.J. Lu Dec. 6, 2020, 2:37 p.m. UTC | #2
On Sun, Dec 6, 2020 at 6:09 AM Florian Weimer <fw@deneb.enyo.de> wrote:
>
> * H. J. Lu:
>
> > On Fri, Dec 4, 2020 at 1:15 PM H.J. Lu <hjl.tools@gmail.com> wrote:
> >>
> >> On Fri, Dec 4, 2020 at 1:13 PM H.J. Lu <hjl.tools@gmail.com> wrote:
> >> >
> >> > On Fri, Dec 4, 2020 at 1:05 PM Florian Weimer <fw@deneb.enyo.de> wrote:
> >> > >
> >> > > * H. J. Lu via Libc-alpha:
> >> > >
> >> > > > Rename linux/i386/readelflib.c to linux/x86/readelflib.c and remove
> >> > > > x86_64/readelflib.c.  Also remove EM_IA_64 support from i386 ldconfig.
> >> > >
> >> > > I'm curious—what's the context for this change?
> >> >
> >> > It is a cleanup job while working on x86-64 ISA level support to ldconfig.
> >> >
> >> > > Do the remaining ia64 systems use an ia64 ldconfig?  (The latest CPUs
> >> > > no longer support i386 IIRC.)
> >> >
> >> > There is a separate, unrelated linux/ia64/readelflib.c.
> >>
> >> With this patch, you can no longer run i386 ldconfig on ia64.   I am not
> >> even sure if it works today.
> >>
> >
> > Here is the patch just to rename.  I have a followup patch for ldconfig
> > to add ISA level check to glibc-hwcaps
>
> I think this is okay.  It would also make sense to process EM_IA_64
> unconditionally in support of qemu-user.

I am checking my patch as is.

Thanks.
diff mbox series

Patch

From 505716a17248207709bb325dbbb1723b228b9553 Mon Sep 17 00:00:00 2001
From: "H.J. Lu" <hjl.tools@gmail.com>
Date: Fri, 4 Dec 2020 12:24:39 -0800
Subject: [PATCH] x86: Rename readelflib.c

Rename linux/i386/readelflib.c to linux/x86/readelflib.c and remove
x86_64/readelflib.c.
---
 sysdeps/unix/sysv/linux/{i386 => x86}/readelflib.c | 4 ++--
 sysdeps/unix/sysv/linux/x86_64/readelflib.c        | 2 --
 2 files changed, 2 insertions(+), 4 deletions(-)
 rename sysdeps/unix/sysv/linux/{i386 => x86}/readelflib.c (98%)
 delete mode 100644 sysdeps/unix/sysv/linux/x86_64/readelflib.c

diff --git a/sysdeps/unix/sysv/linux/i386/readelflib.c b/sysdeps/unix/sysv/linux/x86/readelflib.c
similarity index 98%
rename from sysdeps/unix/sysv/linux/i386/readelflib.c
rename to sysdeps/unix/sysv/linux/x86/readelflib.c
index 05f182734a..3e83419f5b 100644
--- a/sysdeps/unix/sysv/linux/i386/readelflib.c
+++ b/sysdeps/unix/sysv/linux/x86/readelflib.c
@@ -44,7 +44,7 @@  process_elf_file (const char *file_name, const char *lib, int *flag,
 	/* X32 libraries are always libc.so.6+.  */
 	file_flag = FLAG_X8664_LIBX32|FLAG_ELF_LIBC6;
       break;
-#ifndef SKIP_EM_IA_64
+#ifndef __x86_64__
     case EM_IA_64:
       if (elf_header->e_ident[EI_CLASS] == ELFCLASS64)
 	{
@@ -59,7 +59,7 @@  process_elf_file (const char *file_name, const char *lib, int *flag,
 	break;
       /* Fall through.  */
     default:
-#ifndef SKIP_EM_IA_64
+#ifndef __x86_64__
 failed:
 #endif
       error (0, 0, _("%s is for unknown machine %d.\n"),
diff --git a/sysdeps/unix/sysv/linux/x86_64/readelflib.c b/sysdeps/unix/sysv/linux/x86_64/readelflib.c
deleted file mode 100644
index 4c4e5f9d1a..0000000000
--- a/sysdeps/unix/sysv/linux/x86_64/readelflib.c
+++ /dev/null
@@ -1,2 +0,0 @@ 
-#define SKIP_EM_IA_64
-#include <sysdeps/unix/sysv/linux/i386/readelflib.c>
-- 
2.28.0