diff mbox

[RFC,i386] Adjust unroll factor for bdver3 and bdver4

Message ID EB4625145972F94C9680D8CADD6516155E7988DB@satlexdag03.amd.com
State New
Headers show

Commit Message

Gopalasubramanian, Ganesh Dec. 19, 2013, 10:01 a.m. UTC
> Please provide updated ChangeLog.


> Otherwise, the patch looks OK.
Thanks.  Bootstrapping passes. Is it OK for upstream?

> BTW: Please avoid top-posting, see e.g. [1] for reasons...
Sorry for the lapse. Will comply.

Regards
Ganesh

Comments

Uros Bizjak Dec. 19, 2013, 10:15 a.m. UTC | #1
On Thu, Dec 19, 2013 at 11:01 AM, Gopalasubramanian, Ganesh
<Ganesh.Gopalasubramanian@amd.com> wrote:
>> Please provide updated ChangeLog.
>
> --- gcc/ChangeLog       (revision 206106)
> +++ gcc/ChangeLog       (working copy)
> @@ -1,3 +1,14 @@
> +2013-12-19  Ganesh Gopalasubramanian  <Ganesh.Gopalasubramanian@amd.com>
> +
> +       * config/i386/i386.c: Include cfgloop.h.
> +       (ix86_loop_memcount): New function.
> +       (ix86_loop_unroll_adjust): New function.
> +       (TARGET_LOOP_UNROLL_ADJUST): Define.
> +       * config/i386/i386.h
> +       (TARGET_ADJUST_UNROLL): Define.
> +       * config/i386/x86-tune.def
> +       (X86_TUNE_ADJUST_UNROLL): Define.
> +
>
>> The function comment is missing. Maybe you should also describe magic number 32 here?
> Added the function comment.
>
>> Otherwise, the patch looks OK.
> Thanks.  Bootstrapping passes. Is it OK for upstream?

OK.

Thanks,
Uros.
diff mbox

Patch

--- gcc/ChangeLog	(revision 206106)
+++ gcc/ChangeLog	(working copy)
@@ -1,3 +1,14 @@ 
+2013-12-19  Ganesh Gopalasubramanian  <Ganesh.Gopalasubramanian@amd.com>
+
+	* config/i386/i386.c: Include cfgloop.h. 
+	(ix86_loop_memcount): New function.
+	(ix86_loop_unroll_adjust): New function.
+	(TARGET_LOOP_UNROLL_ADJUST): Define.
+	* config/i386/i386.h
+	(TARGET_ADJUST_UNROLL): Define.
+	* config/i386/x86-tune.def
+	(X86_TUNE_ADJUST_UNROLL): Define.
+

> The function comment is missing. Maybe you should also describe magic number 32 here?
Added the function comment.