diff mbox

[PATCHv3,ARM] -mpure-code option for ARM

Message ID CAFULd4YCdAaD+iw_FFn=1b-0dtrX_WmMOGdJ=tsZKO_aA=z9+w@mail.gmail.com
State New
Headers show

Commit Message

Uros Bizjak Sept. 22, 2016, 8:37 p.m. UTC
The name of this hook doesn't adhere to the convention. It should be named:

hook_bool_uint_uintp_false

Uros.
diff mbox

Patch

diff --git a/gcc/hooks.c b/gcc/hooks.c
index 99ec4014adb6fcbb073bf538dd00fe8695ee6cb2..1e925645c3173f8d97e104b9b2f480fca2ede438
100644
--- a/gcc/hooks.c
+++ b/gcc/hooks.c
@@ -481,3 +481,13 @@  void
  hook_void_gcc_optionsp (struct gcc_options *opts ATTRIBUTE_UNUSED)
  {
  }
+
+/* Generic hook that takes an unsigned int, an unsigned int pointer and
+   returns false.  */
+
+bool
+hook_uint_uintp_false (unsigned int, unsigned int *)
+{
+  return false;
+}