diff mbox series

[COMMITTED] gcc: xtensa: use GP_RETURN_* instead of magic constant

Message ID 20221229171432.236445-1-jcmvbkbc@gmail.com
State New
Headers show
Series [COMMITTED] gcc: xtensa: use GP_RETURN_* instead of magic constant | expand

Commit Message

Max Filippov Dec. 29, 2022, 5:14 p.m. UTC
gcc/
	* config/xtensa/xtensa.cc (xtensa_return_in_memory): Use
	GP_RETURN_* instead of magic constant.
---
 gcc/config/xtensa/xtensa.cc | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gcc/config/xtensa/xtensa.cc b/gcc/config/xtensa/xtensa.cc
index e726a115029f..ae44199bc988 100644
--- a/gcc/config/xtensa/xtensa.cc
+++ b/gcc/config/xtensa/xtensa.cc
@@ -4516,7 +4516,7 @@  static bool
 xtensa_return_in_memory (const_tree type, const_tree fntype ATTRIBUTE_UNUSED)
 {
   return ((unsigned HOST_WIDE_INT) int_size_in_bytes (type)
-	  > 4 * UNITS_PER_WORD);
+	  > (unsigned) (GP_RETURN_LAST - GP_RETURN_FIRST + 1) * UNITS_PER_WORD);
 }
 
 /* Worker function for TARGET_FUNCTION_VALUE.  */