diff mbox series

[1/3] Debian: update compat level and standards version to match Xenial

Message ID 20200730120122.24506-1-colin.king@canonical.com
State Accepted
Headers show
Series [1/3] Debian: update compat level and standards version to match Xenial | expand

Commit Message

Colin King July 30, 2020, 12:01 p.m. UTC
From: Colin Ian King <colin.king@canonical.com>

Ubuntu Xenial is the oldest supported fwts release, change the compat
level and standards version to match the requirements for Xenial

Signed-off-by: Colin Ian King <colin.king@canonical.com>
---
 debian/compat  |  2 +-
 debian/control | 41 +++++++++++++++++++++++++++++++++--------
 2 files changed, 34 insertions(+), 9 deletions(-)

Comments

Alex Hung July 30, 2020, 7:17 p.m. UTC | #1
On 2020-07-30 6:01 a.m., Colin King wrote:
> From: Colin Ian King <colin.king@canonical.com>
> 
> Ubuntu Xenial is the oldest supported fwts release, change the compat
> level and standards version to match the requirements for Xenial
> 
> Signed-off-by: Colin Ian King <colin.king@canonical.com>
> ---
>  debian/compat  |  2 +-
>  debian/control | 41 +++++++++++++++++++++++++++++++++--------
>  2 files changed, 34 insertions(+), 9 deletions(-)
> 
> diff --git a/debian/compat b/debian/compat
> index 7f8f011..45a4fb7 100644
> --- a/debian/compat
> +++ b/debian/compat
> @@ -1 +1 @@
> -7
> +8
> diff --git a/debian/control b/debian/control
> index dffe027..e4fe041 100644
> --- a/debian/control
> +++ b/debian/control
> @@ -3,12 +3,31 @@ Section: devel
>  Priority: optional
>  Maintainer: Firmware Testing Team <fwts-devel@lists.ubuntu.com>
>  Uploaders: Colin King <colin.king@ubuntu.com>, Alex Hung <alex.hung@canonical.com>, Ivan Hu <ivan.hu@canonical.com>
> -Standards-Version: 3.9.8
> -Build-Depends: debhelper (>= 7.0.50~), autoconf, automake, libtool, libjson0-dev | libjson-c-dev (>= 0.9), flex, bison, dh-autoreconf, dkms, libglib2.0-dev, pkg-config, libfdt-dev, libbsd-dev
> +Standards-Version: 3.9.7
> +Build-Depends: debhelper (>= 9~),
> +               autoconf,
> +               automake,
> +               libtool,
> +               libjson0-dev | libjson-c-dev (>= 0.9),
> +               flex,
> +               bison,
> +               dh-autoreconf,
> +               dkms,
> +               libglib2.0-dev,
> +               pkg-config,
> +               libfdt-dev,
> +               libbsd-dev
>  
>  Package: fwts
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
> -Depends: libfwtsiasl1 (= ${binary:Version}), libfwtsacpica1 (= ${binary:Version}), libfwts1 (= ${binary:Version}), fwts-efi-runtime-dkms (= ${binary:Version}) [amd64] , ${shlibs:Depends}, ${misc:Depends}, pciutils, device-tree-compiler [ppc64el powerpc]
> +Depends: libfwtsiasl1 (= ${binary:Version}),
> +         libfwtsacpica1 (= ${binary:Version}),
> +         libfwts1 (= ${binary:Version}),
> +         fwts-efi-runtime-dkms (= ${binary:Version}) [amd64],
> +         ${shlibs:Depends},
> +         ${misc:Depends},
> +         pciutils,
> +         device-tree-compiler [ppc64el powerpc]
>  Suggests: dmidecode
>  Description: FirmWare Test Suite
>   This is a firmware test suite that performs sanity checks on system
> @@ -19,7 +38,8 @@ Description: FirmWare Test Suite
>  
>  Package: libfwtsiasl1
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
> -Depends: ${shlibs:Depends}, ${misc:Depends}
> +Depends: ${shlibs:Depends},
> +         ${misc:Depends}
>  Description: FirmWare Test Suite ACPICA core built for iasl functionality
>   The firmware test suite requires the ACPICA core engine to be built in
>   compiler mode (with ACPI_ASL_COMPILER enabled) to support assembly and 
> @@ -29,7 +49,8 @@ Description: FirmWare Test Suite ACPICA core built for iasl functionality
>  
>  Package: libfwtsacpica1
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
> -Depends: ${shlibs:Depends}, ${misc:Depends}
> +Depends: ${shlibs:Depends},
> +         ${misc:Depends}
>  Description: FirmWare Test Suite ACPICA core built for acpiexec functionality
>   The firmware test suite requires the ACPICA core engine to be built in
>   execution mode (with ACPI_EXEC_APP enabled) to support run time execution
> @@ -38,7 +59,8 @@ Description: FirmWare Test Suite ACPICA core built for acpiexec functionality
>  
>  Package: libfwts1
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
> -Depends: ${shlibs:Depends}, ${misc:Depends}
> +Depends: ${shlibs:Depends},
> +         ${misc:Depends}
>  Description: FirmWare Test Suite core support library
>   This is the fwts core library. It contains a top level test framework
>   and a rich range of firmware specific testing support code for the 
> @@ -47,7 +69,9 @@ Description: FirmWare Test Suite core support library
>  Package: fwts-frontend
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
>  Priority: optional
> -Depends: ${misc:Depends}, dialog, fwts
> +Depends: ${misc:Depends},
> +         dialog,
> +         fwts
>  Description: Firmware Test Suite frontend interface
>   This is a dialog based interface designed to provide an easy to use method
>   to execute tests via Firmware Test Suite and is also used as the primary 
> @@ -56,7 +80,8 @@ Description: Firmware Test Suite frontend interface
>  Package: fwts-efi-runtime-dkms
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el
>  Priority: optional
> -Depends: ${misc:Depends}, dkms
> +Depends: ${misc:Depends},
> +         dkms
>  Description: Firmware Test Suite UEFI Runtime Service kernel driver
>   This package provides the efi_runtime kernel driver in DKMS format,
>   which is required for accessing UEFI Runtime Services.
> 

Acked-by: Alex Hung <alex.hung@canonical.com>
ivanhu Aug. 3, 2020, 7:05 a.m. UTC | #2
On 7/30/20 8:01 PM, Colin King wrote:
> From: Colin Ian King <colin.king@canonical.com>
> 
> Ubuntu Xenial is the oldest supported fwts release, change the compat
> level and standards version to match the requirements for Xenial
> 
> Signed-off-by: Colin Ian King <colin.king@canonical.com>
> ---
>  debian/compat  |  2 +-
>  debian/control | 41 +++++++++++++++++++++++++++++++++--------
>  2 files changed, 34 insertions(+), 9 deletions(-)
> 
> diff --git a/debian/compat b/debian/compat
> index 7f8f011..45a4fb7 100644
> --- a/debian/compat
> +++ b/debian/compat
> @@ -1 +1 @@
> -7
> +8
> diff --git a/debian/control b/debian/control
> index dffe027..e4fe041 100644
> --- a/debian/control
> +++ b/debian/control
> @@ -3,12 +3,31 @@ Section: devel
>  Priority: optional
>  Maintainer: Firmware Testing Team <fwts-devel@lists.ubuntu.com>
>  Uploaders: Colin King <colin.king@ubuntu.com>, Alex Hung <alex.hung@canonical.com>, Ivan Hu <ivan.hu@canonical.com>
> -Standards-Version: 3.9.8
> -Build-Depends: debhelper (>= 7.0.50~), autoconf, automake, libtool, libjson0-dev | libjson-c-dev (>= 0.9), flex, bison, dh-autoreconf, dkms, libglib2.0-dev, pkg-config, libfdt-dev, libbsd-dev
> +Standards-Version: 3.9.7
> +Build-Depends: debhelper (>= 9~),
> +               autoconf,
> +               automake,
> +               libtool,
> +               libjson0-dev | libjson-c-dev (>= 0.9),
> +               flex,
> +               bison,
> +               dh-autoreconf,
> +               dkms,
> +               libglib2.0-dev,
> +               pkg-config,
> +               libfdt-dev,
> +               libbsd-dev
>  
>  Package: fwts
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
> -Depends: libfwtsiasl1 (= ${binary:Version}), libfwtsacpica1 (= ${binary:Version}), libfwts1 (= ${binary:Version}), fwts-efi-runtime-dkms (= ${binary:Version}) [amd64] , ${shlibs:Depends}, ${misc:Depends}, pciutils, device-tree-compiler [ppc64el powerpc]
> +Depends: libfwtsiasl1 (= ${binary:Version}),
> +         libfwtsacpica1 (= ${binary:Version}),
> +         libfwts1 (= ${binary:Version}),
> +         fwts-efi-runtime-dkms (= ${binary:Version}) [amd64],
> +         ${shlibs:Depends},
> +         ${misc:Depends},
> +         pciutils,
> +         device-tree-compiler [ppc64el powerpc]
>  Suggests: dmidecode
>  Description: FirmWare Test Suite
>   This is a firmware test suite that performs sanity checks on system
> @@ -19,7 +38,8 @@ Description: FirmWare Test Suite
>  
>  Package: libfwtsiasl1
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
> -Depends: ${shlibs:Depends}, ${misc:Depends}
> +Depends: ${shlibs:Depends},
> +         ${misc:Depends}
>  Description: FirmWare Test Suite ACPICA core built for iasl functionality
>   The firmware test suite requires the ACPICA core engine to be built in
>   compiler mode (with ACPI_ASL_COMPILER enabled) to support assembly and 
> @@ -29,7 +49,8 @@ Description: FirmWare Test Suite ACPICA core built for iasl functionality
>  
>  Package: libfwtsacpica1
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
> -Depends: ${shlibs:Depends}, ${misc:Depends}
> +Depends: ${shlibs:Depends},
> +         ${misc:Depends}
>  Description: FirmWare Test Suite ACPICA core built for acpiexec functionality
>   The firmware test suite requires the ACPICA core engine to be built in
>   execution mode (with ACPI_EXEC_APP enabled) to support run time execution
> @@ -38,7 +59,8 @@ Description: FirmWare Test Suite ACPICA core built for acpiexec functionality
>  
>  Package: libfwts1
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
> -Depends: ${shlibs:Depends}, ${misc:Depends}
> +Depends: ${shlibs:Depends},
> +         ${misc:Depends}
>  Description: FirmWare Test Suite core support library
>   This is the fwts core library. It contains a top level test framework
>   and a rich range of firmware specific testing support code for the 
> @@ -47,7 +69,9 @@ Description: FirmWare Test Suite core support library
>  Package: fwts-frontend
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
>  Priority: optional
> -Depends: ${misc:Depends}, dialog, fwts
> +Depends: ${misc:Depends},
> +         dialog,
> +         fwts
>  Description: Firmware Test Suite frontend interface
>   This is a dialog based interface designed to provide an easy to use method
>   to execute tests via Firmware Test Suite and is also used as the primary 
> @@ -56,7 +80,8 @@ Description: Firmware Test Suite frontend interface
>  Package: fwts-efi-runtime-dkms
>  Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el
>  Priority: optional
> -Depends: ${misc:Depends}, dkms
> +Depends: ${misc:Depends},
> +         dkms
>  Description: Firmware Test Suite UEFI Runtime Service kernel driver
>   This package provides the efi_runtime kernel driver in DKMS format,
>   which is required for accessing UEFI Runtime Services.
> 

Acked-by: Ivan Hu <ivan.hu@canonical.com>
diff mbox series

Patch

diff --git a/debian/compat b/debian/compat
index 7f8f011..45a4fb7 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@ 
-7
+8
diff --git a/debian/control b/debian/control
index dffe027..e4fe041 100644
--- a/debian/control
+++ b/debian/control
@@ -3,12 +3,31 @@  Section: devel
 Priority: optional
 Maintainer: Firmware Testing Team <fwts-devel@lists.ubuntu.com>
 Uploaders: Colin King <colin.king@ubuntu.com>, Alex Hung <alex.hung@canonical.com>, Ivan Hu <ivan.hu@canonical.com>
-Standards-Version: 3.9.8
-Build-Depends: debhelper (>= 7.0.50~), autoconf, automake, libtool, libjson0-dev | libjson-c-dev (>= 0.9), flex, bison, dh-autoreconf, dkms, libglib2.0-dev, pkg-config, libfdt-dev, libbsd-dev
+Standards-Version: 3.9.7
+Build-Depends: debhelper (>= 9~),
+               autoconf,
+               automake,
+               libtool,
+               libjson0-dev | libjson-c-dev (>= 0.9),
+               flex,
+               bison,
+               dh-autoreconf,
+               dkms,
+               libglib2.0-dev,
+               pkg-config,
+               libfdt-dev,
+               libbsd-dev
 
 Package: fwts
 Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
-Depends: libfwtsiasl1 (= ${binary:Version}), libfwtsacpica1 (= ${binary:Version}), libfwts1 (= ${binary:Version}), fwts-efi-runtime-dkms (= ${binary:Version}) [amd64] , ${shlibs:Depends}, ${misc:Depends}, pciutils, device-tree-compiler [ppc64el powerpc]
+Depends: libfwtsiasl1 (= ${binary:Version}),
+         libfwtsacpica1 (= ${binary:Version}),
+         libfwts1 (= ${binary:Version}),
+         fwts-efi-runtime-dkms (= ${binary:Version}) [amd64],
+         ${shlibs:Depends},
+         ${misc:Depends},
+         pciutils,
+         device-tree-compiler [ppc64el powerpc]
 Suggests: dmidecode
 Description: FirmWare Test Suite
  This is a firmware test suite that performs sanity checks on system
@@ -19,7 +38,8 @@  Description: FirmWare Test Suite
 
 Package: libfwtsiasl1
 Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends: ${shlibs:Depends},
+         ${misc:Depends}
 Description: FirmWare Test Suite ACPICA core built for iasl functionality
  The firmware test suite requires the ACPICA core engine to be built in
  compiler mode (with ACPI_ASL_COMPILER enabled) to support assembly and 
@@ -29,7 +49,8 @@  Description: FirmWare Test Suite ACPICA core built for iasl functionality
 
 Package: libfwtsacpica1
 Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends: ${shlibs:Depends},
+         ${misc:Depends}
 Description: FirmWare Test Suite ACPICA core built for acpiexec functionality
  The firmware test suite requires the ACPICA core engine to be built in
  execution mode (with ACPI_EXEC_APP enabled) to support run time execution
@@ -38,7 +59,8 @@  Description: FirmWare Test Suite ACPICA core built for acpiexec functionality
 
 Package: libfwts1
 Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends: ${shlibs:Depends},
+         ${misc:Depends}
 Description: FirmWare Test Suite core support library
  This is the fwts core library. It contains a top level test framework
  and a rich range of firmware specific testing support code for the 
@@ -47,7 +69,9 @@  Description: FirmWare Test Suite core support library
 Package: fwts-frontend
 Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el s390x riscv64
 Priority: optional
-Depends: ${misc:Depends}, dialog, fwts
+Depends: ${misc:Depends},
+         dialog,
+         fwts
 Description: Firmware Test Suite frontend interface
  This is a dialog based interface designed to provide an easy to use method
  to execute tests via Firmware Test Suite and is also used as the primary 
@@ -56,7 +80,8 @@  Description: Firmware Test Suite frontend interface
 Package: fwts-efi-runtime-dkms
 Architecture: i386 amd64 armel armhf arm64 ppc64 ppc64el
 Priority: optional
-Depends: ${misc:Depends}, dkms
+Depends: ${misc:Depends},
+         dkms
 Description: Firmware Test Suite UEFI Runtime Service kernel driver
  This package provides the efi_runtime kernel driver in DKMS format,
  which is required for accessing UEFI Runtime Services.