diff mbox series

[v3,2/4] dt-bindings: gpio: fsl-imx-gpio: add i.MX ARMv6 and ARMv7 compatibles

Message ID 20200920195848.27075-2-krzk@kernel.org
State Not Applicable
Headers show
Series [v3,1/4] dt-bindings: gpio: pl061: add gpio-line-names | expand

Checks

Context Check Description
robh/checkpatch warning total: 0 errors, 1 warnings, 20 lines checked

Commit Message

Krzysztof Kozlowski Sept. 20, 2020, 7:58 p.m. UTC
Several DTSes with ARMv6 and ARMv7 i.MX SoCs introduce their own
compatibles so add them to fix dtbs_check warnings like:

  arch/arm/boot/dts/imx35-pdk.dt.yaml: gpio@53fa4000:
    compatible: ['fsl,imx35-gpio', 'fsl,imx31-gpio'] is not valid under any of the given schemas

  arch/arm/boot/dts/imx51-babbage.dt.yaml: gpio@73f90000:
    compatible: ['fsl,imx51-gpio', 'fsl,imx35-gpio'] is not valid under any of the given schemas

Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>

---

Changes since v2:
1. None, split from previous patchset using common GPIO schema
---
 .../devicetree/bindings/gpio/fsl-imx-gpio.yaml       | 12 ++++++++++++
 1 file changed, 12 insertions(+)

Comments

Rob Herring Sept. 23, 2020, 9:08 p.m. UTC | #1
On Sun, 20 Sep 2020 21:58:46 +0200, Krzysztof Kozlowski wrote:
> Several DTSes with ARMv6 and ARMv7 i.MX SoCs introduce their own
> compatibles so add them to fix dtbs_check warnings like:
> 
>   arch/arm/boot/dts/imx35-pdk.dt.yaml: gpio@53fa4000:
>     compatible: ['fsl,imx35-gpio', 'fsl,imx31-gpio'] is not valid under any of the given schemas
> 
>   arch/arm/boot/dts/imx51-babbage.dt.yaml: gpio@73f90000:
>     compatible: ['fsl,imx51-gpio', 'fsl,imx35-gpio'] is not valid under any of the given schemas
> 
> Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> 
> ---
> 
> Changes since v2:
> 1. None, split from previous patchset using common GPIO schema
> ---
>  .../devicetree/bindings/gpio/fsl-imx-gpio.yaml       | 12 ++++++++++++
>  1 file changed, 12 insertions(+)
> 

Reviewed-by: Rob Herring <robh@kernel.org>
Linus Walleij Sept. 29, 2020, 11:52 a.m. UTC | #2
On Sun, Sep 20, 2020 at 9:59 PM Krzysztof Kozlowski <krzk@kernel.org> wrote:

> Several DTSes with ARMv6 and ARMv7 i.MX SoCs introduce their own
> compatibles so add them to fix dtbs_check warnings like:
>
>   arch/arm/boot/dts/imx35-pdk.dt.yaml: gpio@53fa4000:
>     compatible: ['fsl,imx35-gpio', 'fsl,imx31-gpio'] is not valid under any of the given schemas
>
>   arch/arm/boot/dts/imx51-babbage.dt.yaml: gpio@73f90000:
>     compatible: ['fsl,imx51-gpio', 'fsl,imx35-gpio'] is not valid under any of the given schemas
>
> Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>

Patch applied.

Yours,
Linus Walleij
diff mbox series

Patch

diff --git a/Documentation/devicetree/bindings/gpio/fsl-imx-gpio.yaml b/Documentation/devicetree/bindings/gpio/fsl-imx-gpio.yaml
index de0b9b5f6a70..281cdd34a829 100644
--- a/Documentation/devicetree/bindings/gpio/fsl-imx-gpio.yaml
+++ b/Documentation/devicetree/bindings/gpio/fsl-imx-gpio.yaml
@@ -18,8 +18,20 @@  properties:
           - fsl,imx31-gpio
           - fsl,imx35-gpio
           - fsl,imx7d-gpio
+      - items:
+          - const: fsl,imx35-gpio
+          - const: fsl,imx31-gpio
       - items:
           - enum:
+              - fsl,imx50-gpio
+              - fsl,imx51-gpio
+              - fsl,imx53-gpio
+              - fsl,imx6q-gpio
+              - fsl,imx6sl-gpio
+              - fsl,imx6sll-gpio
+              - fsl,imx6sx-gpio
+              - fsl,imx6ul-gpio
+              - fsl,imx7d-gpio
               - fsl,imx8mm-gpio
               - fsl,imx8mn-gpio
               - fsl,imx8mp-gpio