diff mbox series

[v3,1/3] dt: bindings: net: update compatible for ath11k

Message ID 1592458104-2961-2-git-send-email-akolli@codeaurora.org
State Changes Requested
Headers show
Series ath11k: Add IPQ6018 support | expand

Checks

Context Check Description
robh/dt-meta-schema success
robh/checkpatch success

Commit Message

Anilkumar Kolli June 18, 2020, 5:28 a.m. UTC
Add IPQ6018 wireless driver support,
its based on ath11k driver.

Signed-off-by: Anilkumar Kolli <akolli@codeaurora.org>
---
V3:
 - Use 'enum' rather than oneOf+const.

 Documentation/devicetree/bindings/net/wireless/qcom,ath11k.yaml | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Rob Herring July 13, 2020, 6:51 p.m. UTC | #1
On Thu, Jun 18, 2020 at 10:58:22AM +0530, Anilkumar Kolli wrote:
> Add IPQ6018 wireless driver support,
> its based on ath11k driver.
> 
> Signed-off-by: Anilkumar Kolli <akolli@codeaurora.org>
> ---
> V3:
>  - Use 'enum' rather than oneOf+const.
> 
>  Documentation/devicetree/bindings/net/wireless/qcom,ath11k.yaml | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
> 
> diff --git a/Documentation/devicetree/bindings/net/wireless/qcom,ath11k.yaml b/Documentation/devicetree/bindings/net/wireless/qcom,ath11k.yaml
> index a1717db36dba..b22cde6f3594 100644
> --- a/Documentation/devicetree/bindings/net/wireless/qcom,ath11k.yaml
> +++ b/Documentation/devicetree/bindings/net/wireless/qcom,ath11k.yaml
> @@ -17,7 +17,11 @@ description: |
>  
>  properties:
>    compatible:
> -    const: qcom,ipq8074-wifi
> +    oneOf:
> +      - items:
> +          - enum:
> +              - qcom,ipq8074-wifi
> +              - qcom,ipq6018-wifi

Just need:

enum:
  - qcom,ipq8074-wifi
  - qcom,ipq6018-wifi
diff mbox series

Patch

diff --git a/Documentation/devicetree/bindings/net/wireless/qcom,ath11k.yaml b/Documentation/devicetree/bindings/net/wireless/qcom,ath11k.yaml
index a1717db36dba..b22cde6f3594 100644
--- a/Documentation/devicetree/bindings/net/wireless/qcom,ath11k.yaml
+++ b/Documentation/devicetree/bindings/net/wireless/qcom,ath11k.yaml
@@ -17,7 +17,11 @@  description: |
 
 properties:
   compatible:
-    const: qcom,ipq8074-wifi
+    oneOf:
+      - items:
+          - enum:
+              - qcom,ipq8074-wifi
+              - qcom,ipq6018-wifi
 
   reg:
     maxItems: 1