mbox series

[v3,00/14] NVIDIA Tegra ARM32 device-tree patches for 5.17 (new devices and more)

Message ID 20211127142327.17692-1-digetx@gmail.com
Headers show
Series NVIDIA Tegra ARM32 device-tree patches for 5.17 (new devices and more) | expand

Message

Dmitry Osipenko Nov. 27, 2021, 2:23 p.m. UTC
In this patchset you will find:

  - New device-trees of ASUS Transformer and Pegatron Chagall tablets.

  - New device-tree of Nyan Big Chromebook variant that has 1080p display
    panel.

  - Enabled video decoder on Tegra114.

  - Minor cleanup of Nexus7 device-tree.

  - Renamed clocks and regulator nodes. I'm sending this patch second time
    because previously there was no good reason given about why not to apply
    it. Please apply it this time.

Changelog:

v3: - Maxim added couple "FIXME" comments to Transformer device-trees for
      things that are yet missing on kernel side, and thus, can't be enabled
      in the DT for now.

    - Maxim also found that v2 had a small problem in the patch which adds
      device-tree for Chagall tablet. Turned out I made a mistake during
      rebase of the patches and haven't noticed it, it's fixed now.

v2: - Svyatoslav and Maxim made couple corrections to regulators, comments
      and default brightness of the device-trees.

    - Added thermtrip node to transformers DT as we now have PMIC fix for
      it [1], it works properly now.

      [1] https://patchwork.ozlabs.org/project/linux-tegra/patch/20211124190104.23554-1-digetx@gmail.com/

    - Changed sound card model names to make them per-device and consistent
      with the names that other Tegra DTs already use in upstream. This will
      prevent potential ABI breakages in the future if we will find that sound
      of some device needs extra differentiation.

Anton Bambura (3):
  ARM: tegra: Add labels to tegra114.dtsi
  ARM: tegra: Add device-tree for ASUS Transformer Pad TF701T
  ARM: tegra: Enable video decoder on Tegra114

David Heidelberg (3):
  dt-bindings: ARM: tegra: Document Pegatron Chagall
  ARM: tegra: Name clock and regulator nodes according to DT-schema
  ARM: tegra: nexus7: Drop clock-frequency from NFC node

Dmitry Osipenko (1):
  ARM: tegra: Add device-tree for 1080p version of Nyan Big

Michał Mirosław (1):
  ARM: tegra: Add device-tree for ASUS Transformer Pad TF300T

Nikola Milosavljevic (1):
  ARM: tegra: Add device-tree for ASUS Transformer EeePad TF101

Svyatoslav Ryhel (5):
  dt-bindings: ARM: tegra: Document ASUS Transformers
  ARM: tegra: Add device-tree for ASUS Transformer Prime TF201
  ARM: tegra: Add device-tree for ASUS Transformer Pad TF300TG
  ARM: tegra: Add device-tree for ASUS Transformer Infinity TF700T
  ARM: tegra: Add device-tree for Pegatron Chagall tablet

 .../devicetree/bindings/arm/tegra.yaml        |   19 +
 arch/arm/boot/dts/Makefile                    |   10 +-
 arch/arm/boot/dts/tegra114-asus-tf701t.dts    |  833 +++++
 arch/arm/boot/dts/tegra114-dalmore.dts        |   16 +-
 arch/arm/boot/dts/tegra114-roth.dts           |   14 +-
 arch/arm/boot/dts/tegra114-tn7.dts            |    8 +-
 arch/arm/boot/dts/tegra114.dtsi               |   90 +-
 arch/arm/boot/dts/tegra124-jetson-tk1.dts     |   26 +-
 arch/arm/boot/dts/tegra124-nyan-big-fhd.dts   |   11 +
 arch/arm/boot/dts/tegra124-nyan.dtsi          |   28 +-
 arch/arm/boot/dts/tegra124-venice2.dts        |   28 +-
 .../boot/dts/tegra20-acer-a500-picasso.dts    |   12 +-
 arch/arm/boot/dts/tegra20-asus-tf101.dts      | 1191 +++++++
 arch/arm/boot/dts/tegra20-harmony.dts         |   16 +-
 arch/arm/boot/dts/tegra20-medcom-wide.dts     |    8 +-
 arch/arm/boot/dts/tegra20-paz00.dts           |    6 +-
 arch/arm/boot/dts/tegra20-plutux.dts          |    8 +-
 arch/arm/boot/dts/tegra20-seaboard.dts        |   16 +-
 arch/arm/boot/dts/tegra20-tamonten.dtsi       |    4 +-
 arch/arm/boot/dts/tegra20-tec.dts             |    8 +-
 arch/arm/boot/dts/tegra20-trimslice.dts       |   12 +-
 arch/arm/boot/dts/tegra20-ventana.dts         |   12 +-
 .../boot/dts/tegra30-asus-lvds-display.dtsi   |   46 +
 .../tegra30-asus-nexus7-grouper-common.dtsi   |   10 +-
 ...egra30-asus-nexus7-grouper-maxim-pmic.dtsi |    4 +-
 .../tegra30-asus-nexus7-grouper-ti-pmic.dtsi  |    2 +-
 .../boot/dts/tegra30-asus-nexus7-grouper.dtsi |    1 -
 .../boot/dts/tegra30-asus-nexus7-tilapia.dtsi |    2 -
 arch/arm/boot/dts/tegra30-asus-tf201.dts      |  623 ++++
 arch/arm/boot/dts/tegra30-asus-tf300t.dts     | 1030 ++++++
 arch/arm/boot/dts/tegra30-asus-tf300tg.dts    | 1072 +++++++
 arch/arm/boot/dts/tegra30-asus-tf700t.dts     |  807 +++++
 .../dts/tegra30-asus-transformer-common.dtsi  | 1741 ++++++++++
 arch/arm/boot/dts/tegra30-beaver.dts          |   20 +-
 arch/arm/boot/dts/tegra30-cardhu-a02.dts      |   12 +-
 arch/arm/boot/dts/tegra30-cardhu-a04.dts      |   14 +-
 arch/arm/boot/dts/tegra30-cardhu.dtsi         |   28 +-
 .../arm/boot/dts/tegra30-pegatron-chagall.dts | 2807 +++++++++++++++++
 38 files changed, 10409 insertions(+), 186 deletions(-)
 create mode 100644 arch/arm/boot/dts/tegra114-asus-tf701t.dts
 create mode 100644 arch/arm/boot/dts/tegra124-nyan-big-fhd.dts
 create mode 100644 arch/arm/boot/dts/tegra20-asus-tf101.dts
 create mode 100644 arch/arm/boot/dts/tegra30-asus-lvds-display.dtsi
 create mode 100644 arch/arm/boot/dts/tegra30-asus-tf201.dts
 create mode 100644 arch/arm/boot/dts/tegra30-asus-tf300t.dts
 create mode 100644 arch/arm/boot/dts/tegra30-asus-tf300tg.dts
 create mode 100644 arch/arm/boot/dts/tegra30-asus-tf700t.dts
 create mode 100644 arch/arm/boot/dts/tegra30-asus-transformer-common.dtsi
 create mode 100644 arch/arm/boot/dts/tegra30-pegatron-chagall.dts

Comments

Michał Mirosław Nov. 28, 2021, 1:32 a.m. UTC | #1
On Sat, Nov 27, 2021 at 05:23:16PM +0300, Dmitry Osipenko wrote:
> From: Anton Bambura <jenneron@protonmail.com>
> 
> Add more labels in order to use label reference in device-specific
> dts files. Labels make device-trees more readable and prevent typos
> that are difficult to notice.

I believe that you had also a similar patch for Tegra3 (or my [1]).
Could you pull it into this series to make the DT's easier to manage?

[1] https://rere.qmqm.pl/git/?p=linux;a=commitdiff;h=2c3341163b07d94d209680a22286608d0e4d711a

Best Regards
Michał Mirosław
Michał Mirosław Nov. 28, 2021, 1:51 a.m. UTC | #2
On Sat, Nov 27, 2021 at 05:23:18PM +0300, Dmitry Osipenko wrote:
> From: Svyatoslav Ryhel <clamor95@gmail.com>
> 
> Add device-tree for ASUS Transformer Prime TF201, which is NVIDIA
> Tegra30-based tablet device.
> 
> Co-developed-by: Ion Agorria <ion@agorria.com>
> Signed-off-by: Ion Agorria <ion@agorria.com>
> Co-developed-by: Maxim Schwalm <maxim.schwalm@gmail.com>
> Signed-off-by: Maxim Schwalm <maxim.schwalm@gmail.com>
> Signed-off-by: Svyatoslav Ryhel <clamor95@gmail.com>
> ---
>  arch/arm/boot/dts/Makefile                    |    1 +
>  .../boot/dts/tegra30-asus-lvds-display.dtsi   |   46 +
>  arch/arm/boot/dts/tegra30-asus-tf201.dts      |  623 ++++++
>  .../dts/tegra30-asus-transformer-common.dtsi  | 1741 +++++++++++++++++
>  4 files changed, 2411 insertions(+)
>  create mode 100644 arch/arm/boot/dts/tegra30-asus-lvds-display.dtsi
>  create mode 100644 arch/arm/boot/dts/tegra30-asus-tf201.dts
>  create mode 100644 arch/arm/boot/dts/tegra30-asus-transformer-common.dtsi

I think the common.dtsi is combined from all the DT authors, so they all
should be mentioned in the co-developed/signed-off lines. (Or maybe just
split the common part out if you want to be more specific in assigning
credits?)


> +	i2c@7000c400 {
> +		/* Atmel MXT768E touchscreen */
> +		touchscreen@4d {
[...]
> +			interrupt-parent = <&gpio>;
> +			interrupts = <TEGRA_GPIO(H, 4) IRQ_TYPE_EDGE_FALLING>;
[...]

Nit: This could use 'interrupts-extended' as it's more readable, I think.
(There are similar cases in other DTs.)

> +	uartb: serial@70006040 {
> +		compatible = "nvidia,tegra30-hsuart";
[...]

I wonder why isn't this in the tegra30.dtsi? The DT shouldn't select a
driver - it should only describe the hardware.

Best Regards
Michał Mirosław
Dmitry Osipenko Nov. 28, 2021, 9:12 p.m. UTC | #3
28.11.2021 04:32, Michał Mirosław пишет:
> On Sat, Nov 27, 2021 at 05:23:16PM +0300, Dmitry Osipenko wrote:
>> From: Anton Bambura <jenneron@protonmail.com>
>>
>> Add more labels in order to use label reference in device-specific
>> dts files. Labels make device-trees more readable and prevent typos
>> that are difficult to notice.
> 
> I believe that you had also a similar patch for Tegra3 (or my [1]).
> Could you pull it into this series to make the DT's easier to manage?
> 
> [1] https://rere.qmqm.pl/git/?p=linux;a=commitdiff;h=2c3341163b07d94d209680a22286608d0e4d711a

I had a thought about including it in to this series, but we don't have
a user for that patch right now, so I decided not to include it.

I'll reconsider to include it into v4, now that you're asking about it.
It won't hurt to have that patch, but I really would want somebody to
add a similar patch for T20 and then convert all DTs to use those labels
uniformly, this will take some time and effort to type these patches.
Dmitry Osipenko Nov. 28, 2021, 9:31 p.m. UTC | #4
28.11.2021 04:51, Michał Mirosław пишет:
> On Sat, Nov 27, 2021 at 05:23:18PM +0300, Dmitry Osipenko wrote:
>> From: Svyatoslav Ryhel <clamor95@gmail.com>
>>
>> Add device-tree for ASUS Transformer Prime TF201, which is NVIDIA
>> Tegra30-based tablet device.
>>
>> Co-developed-by: Ion Agorria <ion@agorria.com>
>> Signed-off-by: Ion Agorria <ion@agorria.com>
>> Co-developed-by: Maxim Schwalm <maxim.schwalm@gmail.com>
>> Signed-off-by: Maxim Schwalm <maxim.schwalm@gmail.com>
>> Signed-off-by: Svyatoslav Ryhel <clamor95@gmail.com>
>> ---
>>  arch/arm/boot/dts/Makefile                    |    1 +
>>  .../boot/dts/tegra30-asus-lvds-display.dtsi   |   46 +
>>  arch/arm/boot/dts/tegra30-asus-tf201.dts      |  623 ++++++
>>  .../dts/tegra30-asus-transformer-common.dtsi  | 1741 +++++++++++++++++
>>  4 files changed, 2411 insertions(+)
>>  create mode 100644 arch/arm/boot/dts/tegra30-asus-lvds-display.dtsi
>>  create mode 100644 arch/arm/boot/dts/tegra30-asus-tf201.dts
>>  create mode 100644 arch/arm/boot/dts/tegra30-asus-transformer-common.dtsi
> 
> I think the common.dtsi is combined from all the DT authors, so they all
> should be mentioned in the co-developed/signed-off lines. (Or maybe just
> split the common part out if you want to be more specific in assigning
> credits?)

I'll factor out the common part into separate patch and will make you
the author of that patch since it really was derived from yours original
TF300T DT. I actually wanted to do that previously, it's good that you
reminded about it.

>> +	i2c@7000c400 {
>> +		/* Atmel MXT768E touchscreen */
>> +		touchscreen@4d {
> [...]
>> +			interrupt-parent = <&gpio>;
>> +			interrupts = <TEGRA_GPIO(H, 4) IRQ_TYPE_EDGE_FALLING>;
> [...]
> 
> Nit: This could use 'interrupts-extended' as it's more readable, I think.
> (There are similar cases in other DTs.)

I don't have objections, although the classic variant is also good to me.

I don't think that it makes sense to change only the Transformer DTs to
use 'interrupts-extended'. I'd suggest to create a followup patches that
will cleanup and improve all Tegra device-trees together, making them
all more uniform and nicer to look.

>> +	uartb: serial@70006040 {
>> +		compatible = "nvidia,tegra30-hsuart";
> [...]
> 
> I wonder why isn't this in the tegra30.dtsi? The DT shouldn't select a
> driver - it should only describe the hardware.

The "nvidia,tegra30-hsuart" implies that UART port is capable of
performing the high speed transfers, which should be board dependent.
Meanwhile "nvidia,tegra30-uart" should work for all hardware variants.
That's how I understand it.

The comment in the Tegra dtsi really shouldn't refer to the drivers.
Changing that comment should be material for a separate patch. It could
become a part of the DT cleanup patches together with the
'interrupts-extended' changes.