diff mbox

iproute2: disable xtables on static build

Message ID fa972eff514e12b82ce7d6c557950f6e63b57724.1432188465.git.baruch@tkos.co.il
State Accepted
Commit 72e548a48036dce6a7ee5cfebc7cdefd9ffb8442
Headers show

Commit Message

Baruch Siach May 21, 2015, 6:07 a.m. UTC
iproute2 always builds m_xt.so as a shared library.

Fixes:
http://autobuild.buildroot.net/results/f42/f42bbbf5be4594a8806d0e571586ce2bf119582d/
http://autobuild.buildroot.net/results/3b3/3b37871bdf5766677fc20dca22c13177091d104f/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/iproute2/iproute2.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni May 21, 2015, 10:02 a.m. UTC | #1
Dear Baruch Siach,

On Thu, 21 May 2015 09:07:45 +0300, Baruch Siach wrote:
> iproute2 always builds m_xt.so as a shared library.
> 
> Fixes:
> http://autobuild.buildroot.net/results/f42/f42bbbf5be4594a8806d0e571586ce2bf119582d/
> http://autobuild.buildroot.net/results/3b3/3b37871bdf5766677fc20dca22c13177091d104f/
> 
> Signed-off-by: Baruch Siach <baruch@tkos.co.il>
> ---
>  package/iproute2/iproute2.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)

There was already a patch posted by Romain for the same issue,
http://patchwork.ozlabs.org/patch/473600/. Some discussion with
Peter/Gustavo followed. Not clear what the conclusion was, though.

Thomas
Peter Korsgaard May 21, 2015, 9:22 p.m. UTC | #2
>>>>> "Baruch" == Baruch Siach <baruch@tkos.co.il> writes:

 > iproute2 always builds m_xt.so as a shared library.
 > Fixes:
 > http://autobuild.buildroot.net/results/f42/f42bbbf5be4594a8806d0e571586ce2bf119582d/
 > http://autobuild.buildroot.net/results/3b3/3b37871bdf5766677fc20dca22c13177091d104f/

 > Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Committed, thanks.
diff mbox

Patch

diff --git a/package/iproute2/iproute2.mk b/package/iproute2/iproute2.mk
index 9595165ec6a5..3315d67c467c 100644
--- a/package/iproute2/iproute2.mk
+++ b/package/iproute2/iproute2.mk
@@ -18,7 +18,7 @@  IPROUTE2_DEPENDENCIES += busybox
 endif
 
 # If we've got iptables enable xtables support for tc
-ifeq ($(BR2_PACKAGE_IPTABLES),y)
+ifeq ($(BR2_PACKAGE_IPTABLES)x$(BR2_STATIC_LIBS),yx)
 IPROUTE2_DEPENDENCIES += iptables
 define IPROUTE2_WITH_IPTABLES
 	# Makefile is busted so it never passes IPT_LIB_DIR properly
@@ -29,6 +29,7 @@  else
 define IPROUTE2_WITH_IPTABLES
 	# em_ipset needs xtables, but configure misdetects it
 	echo "TC_CONFIG_IPSET:=n" >>$(IPROUTE2_DIR)/Config
+	echo "TC_CONFIG_XT:=n" >>$(IPROUTE2_DIR)/Config
 endef
 endif