diff mbox

[3/8] package/Makefile.in: update/fix HOST_PATH variable

Message ID d29120e810fb080ac4304d6e51b01ec2efda168f.1356907750.git.s.martin49@gmail.com
State Deferred
Headers show

Commit Message

Samuel Martin Dec. 30, 2012, 10:54 p.m. UTC
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
---
 package/Makefile.in | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Arnout Vandecappelle Feb. 7, 2013, 7:07 a.m. UTC | #1
On 30/12/12 23:54, Samuel Martin wrote:
>
> Signed-off-by: Samuel Martin <s.martin49@gmail.com>

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

  This series should still go in for 2013.02, I think.

  Regards,
  Arnout

> ---
>   package/Makefile.in | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/Makefile.in b/package/Makefile.in
> index cc8f320..dd04e25 100644
> --- a/package/Makefile.in
> +++ b/package/Makefile.in
> @@ -165,7 +165,7 @@ HOST_CFLAGS   ?= -O2
>   HOST_CFLAGS   += $(HOST_CPPFLAGS)
>   HOST_CXXFLAGS += $(HOST_CFLAGS)
>   HOST_LDFLAGS  += -L$(HOST_DIR)/lib -L$(HOST_DIR)/usr/lib -Wl,-rpath,$(HOST_DIR)/usr/lib
> -HOST_PATH=$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(PATH)
> +HOST_PATH="$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(HOST_DIR)/usr/sbin/:$(PATH)"
>
>   # hostcc version as an integer - E.G. 4.3.2 => 432
>   HOSTCC_VERSION:=$(shell $(HOSTCC_NOCCACHE) --version | \
>
Thomas Petazzoni Feb. 7, 2013, 8:27 a.m. UTC | #2
Dear Samuel Martin,

On Sun, 30 Dec 2012 23:54:10 +0100, Samuel Martin wrote:
> 
> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
> ---
>  package/Makefile.in | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/Makefile.in b/package/Makefile.in
> index cc8f320..dd04e25 100644
> --- a/package/Makefile.in
> +++ b/package/Makefile.in
> @@ -165,7 +165,7 @@ HOST_CFLAGS   ?= -O2
>  HOST_CFLAGS   += $(HOST_CPPFLAGS)
>  HOST_CXXFLAGS += $(HOST_CFLAGS)
>  HOST_LDFLAGS  += -L$(HOST_DIR)/lib -L$(HOST_DIR)/usr/lib
> -Wl,-rpath,$(HOST_DIR)/usr/lib
> -HOST_PATH=$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(PATH)
> +HOST_PATH="$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(HOST_DIR)/usr/sbin/:$(PATH)" 
>  # hostcc version as an integer - E.G. 4.3.2 => 432
>  HOSTCC_VERSION:=$(shell $(HOSTCC_NOCCACHE) --version | \

I am ok with the patch, and also your 4/8, but I really believe you
should be more verbose in the commit log. Here the only information is
"update/fix HOST_PATH variable". But why? What is the reason? What are
the impacts? It is especially true when we look at those patches with a
little bit of delay as is the case now.

Thanks!

Thomas
Samuel Martin Feb. 7, 2013, 4:48 p.m. UTC | #3
Hi Thomas,

2013/2/7 Thomas Petazzoni <thomas.petazzoni@free-electrons.com>:
> Dear Samuel Martin,
>
> On Sun, 30 Dec 2012 23:54:10 +0100, Samuel Martin wrote:
>>
>> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
>> ---
>>  package/Makefile.in | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/package/Makefile.in b/package/Makefile.in
>> index cc8f320..dd04e25 100644
>> --- a/package/Makefile.in
>> +++ b/package/Makefile.in
>> @@ -165,7 +165,7 @@ HOST_CFLAGS   ?= -O2
>>  HOST_CFLAGS   += $(HOST_CPPFLAGS)
>>  HOST_CXXFLAGS += $(HOST_CFLAGS)
>>  HOST_LDFLAGS  += -L$(HOST_DIR)/lib -L$(HOST_DIR)/usr/lib
>> -Wl,-rpath,$(HOST_DIR)/usr/lib
>> -HOST_PATH=$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(PATH)
>> +HOST_PATH="$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(HOST_DIR)/usr/sbin/:$(PATH)"
>>  # hostcc version as an integer - E.G. 4.3.2 => 432
>>  HOSTCC_VERSION:=$(shell $(HOSTCC_NOCCACHE) --version | \
>
> I am ok with the patch, and also your 4/8, but I really believe you
> should be more verbose in the commit log. Here the only information is
> "update/fix HOST_PATH variable".
I agree and I may be more guilty than anyone else since I regularly
ask for more details. ;)

> But why? What is the reason? What are
> the impacts? It is especially true when we look at those patches with a
> little bit of delay as is the case now.
Well, I think I already answered this:
http://lists.busybox.net/pipermail/buildroot/2012-December/064434.html

I planned to re-spin part of the serie, but would like some inputs to
the question:
"do we need 2 distinct variables for this?"

So, meanwhile, if you prefer merge this patch as is (with a commit
message more verbose), tell me, I'll repost it shortly.

Regards,
diff mbox

Patch

diff --git a/package/Makefile.in b/package/Makefile.in
index cc8f320..dd04e25 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -165,7 +165,7 @@  HOST_CFLAGS   ?= -O2
 HOST_CFLAGS   += $(HOST_CPPFLAGS)
 HOST_CXXFLAGS += $(HOST_CFLAGS)
 HOST_LDFLAGS  += -L$(HOST_DIR)/lib -L$(HOST_DIR)/usr/lib -Wl,-rpath,$(HOST_DIR)/usr/lib
-HOST_PATH=$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(PATH)
+HOST_PATH="$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(HOST_DIR)/usr/sbin/:$(PATH)"
 
 # hostcc version as an integer - E.G. 4.3.2 => 432
 HOSTCC_VERSION:=$(shell $(HOSTCC_NOCCACHE) --version | \