diff mbox

portmap not building static

Message ID F9C551623D2CBB4C9488801D14F864C68C8AD593@ex-mb3.corp.adtran.com
State Superseded
Headers show

Commit Message

ANDY KENNEDY Sept. 8, 2014, 3:46 p.m. UTC
Portmap builds and links, however, does not get built correctly when
BR2_PREFER_STATIC_LIB is selected.  There are no dynamic libraries in 
rootfs.tar, however, portmap gets linked dynamically without regards to
the PREFER_STATIC_LIB tags.  LDFLAGS was not being passed into the build of
portmap.  Fixed.

Signed-off-by:  Andy Kennedy <andy.kennedy@adtran.com>
---
diff mbox

Patch

diff -Naur a/package/portmap/portmap.mk b/package/portmap/portmap.mk
--- a/package/portmap/portmap.mk        2014-02-27 14:51:23.000000000 -0600
+++ b/package/portmap/portmap.mk        2014-09-08 10:38:06.264120676 -0500
@@ -15,7 +15,7 @@ 
 endif
 
 define PORTMAP_BUILD_CMDS
-       CFLAGS="$(TARGET_CFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)" \
        $(MAKE) CC="$(TARGET_CC)" -C $(@D) $(PORTMAP_FLAGS)
 endef