diff mbox

xbmc package

Message ID CAAfyv35s2iDxa8iWXqvfCMQDoF4kk-+_4zDFY=A6sE59i=sHXQ@mail.gmail.com
State Not Applicable
Headers show

Commit Message

Belisko Marek March 28, 2012, 8:47 a.m. UTC
Hi,

I'm trying to add xbmc package to buildroot and have problem how to
fix one dependency problem.
Problem is with mysql_config which is requested by xmbc during config phase.
I add mysql_client dependency (mysql_config is installed in staging)
but xbmc config
still complain. I've check that qt use similar with configure option
but xbmc don't have such an option.

Any ideas how to fix that?

config.log from xmbc attached.



Regards,

marek

Comments

Arnout Vandecappelle March 28, 2012, 9:37 p.m. UTC | #1
On Wednesday 28 March 2012 10:47:52 Belisko Marek wrote:
> Hi,
> 
> I'm trying to add xbmc package to buildroot and have problem how to
> fix one dependency problem.
> Problem is with mysql_config which is requested by xmbc during config phase.
> I add mysql_client dependency (mysql_config is installed in staging)
> but xbmc config
> still complain. I've check that qt use similar with configure option
> but xbmc don't have such an option.
> 
> Any ideas how to fix that?

 You'll have to tell the configure script to look for mysql_config in
the staging directory.  See for instance how fontconfig.mk tells its
configure to use the freetype-config from the staging directory.

 ... except that the xbmc people don't seem to know how to write
a configure.ac.  You can't properly override the MYSQL_CONFIG
variable.  You'll have to fix configure.ac :-(

 The alternative would be to let mysql_client.mk install mysql_config
in some new target-config-bin directory that is prepended to the path
for target builds.  But that's also a lot of work.


[snip]
> diff --git a/package/xbmc/xbmc.mk b/package/xbmc/xbmc.mk
> new file mode 100644
> index 0000000..6379ab8
> --- /dev/null
> +++ b/package/xbmc/xbmc.mk
> @@ -0,0 +1,13 @@
> +#############################################################
> +#
> +# xbmc
> +#
> +#############################################################
> +XBMC_VERSION = 11.0
> +XBMC_SITE = http://mirrors.xbmc.org/releases/source/
> +
> +XBMC_DEPENDENCIES = host-pkg-config boost sdl_gfx mysql_client
> +XBMC_CONF_OPT = --disable-debug --disable-gl

 The --disable-debug should probably be:

$(if $(BR2_ENABLE_DEBUG),--enable-debug,--disable-debug)

 And gl is provided by the mesa3d package - it probably
should be a configure option, though.  Or you can do
something like

ifeq ($(BR2_PACKAGE_MESA3D),y)
XBMC_DEPENDENCIES += mesa3d
XBMC_CONF_OPT += --enable-gl
else
XBMC_CONF_OPT += --disable-gl
endif


 Regards,
 Arnout
Belisko Marek April 2, 2012, 9:51 a.m. UTC | #2
On Wed, Mar 28, 2012 at 11:37 PM, Arnout Vandecappelle <arnout@mind.be> wrote:
> On Wednesday 28 March 2012 10:47:52 Belisko Marek wrote:
>> Hi,
>>
>> I'm trying to add xbmc package to buildroot and have problem how to
>> fix one dependency problem.
>> Problem is with mysql_config which is requested by xmbc during config phase.
>> I add mysql_client dependency (mysql_config is installed in staging)
>> but xbmc config
>> still complain. I've check that qt use similar with configure option
>> but xbmc don't have such an option.
>>
>> Any ideas how to fix that?
>
>  You'll have to tell the configure script to look for mysql_config in
> the staging directory.  See for instance how fontconfig.mk tells its
> configure to use the freetype-config from the staging directory.
>
>  ... except that the xbmc people don't seem to know how to write
> a configure.ac.  You can't properly override the MYSQL_CONFIG
> variable.  You'll have to fix configure.ac :-(
Hmm I'm not an expert of these things. Maybe some pointers could help.
Thanks.
>
>  The alternative would be to let mysql_client.mk install mysql_config
> in some new target-config-bin directory that is prepended to the path
> for target builds.  But that's also a lot of work.
>
>
> [snip]
>> diff --git a/package/xbmc/xbmc.mk b/package/xbmc/xbmc.mk
>> new file mode 100644
>> index 0000000..6379ab8
>> --- /dev/null
>> +++ b/package/xbmc/xbmc.mk
>> @@ -0,0 +1,13 @@
>> +#############################################################
>> +#
>> +# xbmc
>> +#
>> +#############################################################
>> +XBMC_VERSION = 11.0
>> +XBMC_SITE = http://mirrors.xbmc.org/releases/source/
>> +
>> +XBMC_DEPENDENCIES = host-pkg-config boost sdl_gfx mysql_client
>> +XBMC_CONF_OPT = --disable-debug --disable-gl
>
>  The --disable-debug should probably be:
>
> $(if $(BR2_ENABLE_DEBUG),--enable-debug,--disable-debug)
>
>  And gl is provided by the mesa3d package - it probably
> should be a configure option, though.  Or you can do
> something like
>
> ifeq ($(BR2_PACKAGE_MESA3D),y)
> XBMC_DEPENDENCIES += mesa3d
> XBMC_CONF_OPT += --enable-gl
> else
> XBMC_CONF_OPT += --disable-gl
> endif
>
>
>  Regards,
>  Arnout
>
> --
> Arnout Vandecappelle                               arnout at mind be
> Senior Embedded Software Architect                 +32-16-286540
> Essensium/Mind                                     http://www.mind.be
> G.Geenslaan 9, 3001 Leuven, Belgium                BE 872 984 063 RPR Leuven
> LinkedIn profile: http://www.linkedin.com/in/arnoutvandecappelle
> GPG fingerprint:  7CB5 E4CC 6C2E EFD4 6E3D A754 F963 ECAB 2450 2F1F

regards,

marek
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index b394f18..68d28fa 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -120,6 +120,7 @@  source "package/sdl_sound/Config.in"
 source "package/sdl_net/Config.in"
 source "package/sdl_ttf/Config.in"
 source "package/sdl_gfx/Config.in"
+source "package/xbmc/Config.in"

 comment "other GUIs"
 source "package/efl/Config.in"
diff --git a/package/xbmc/Config.in b/package/xbmc/Config.in
new file mode 100644
index 0000000..623e518
--- /dev/null
+++ b/package/xbmc/Config.in
@@ -0,0 +1,7 @@ 
+config BR2_PACKAGE_XBMC
+       bool "xbmc"
+       select BR2_PACKAGE_BOOST
+       select BR2_PACKAGE_SDL_GFX
+       select BR2_PACKAGE_MYSQL_CLIENT
+       help
+         XBMC
diff --git a/package/xbmc/xbmc.mk b/package/xbmc/xbmc.mk
new file mode 100644
index 0000000..6379ab8
--- /dev/null
+++ b/package/xbmc/xbmc.mk
@@ -0,0 +1,13 @@ 
+#############################################################
+#
+# xbmc
+#
+#############################################################
+XBMC_VERSION = 11.0
+XBMC_SITE = http://mirrors.xbmc.org/releases/source/
+
+XBMC_DEPENDENCIES = host-pkg-config boost sdl_gfx mysql_client
+XBMC_CONF_OPT = --disable-debug --disable-gl
+
+$(eval $(call AUTOTARGETS))
+