diff mbox

[1/1,v2] mtools: fix build when libiconv is enabled

Message ID BLU0-SMTP7197D49CF3512366DE9AD5D9780@phx.gbl
State Accepted
Commit 6aee76bcad2022d7c9bd530bef9126ff57035d10
Headers show

Commit Message

Bernd Kuhls March 22, 2014, 1:47 p.m. UTC
Fixes
http://autobuild.buildroot.net/results/298/298858b6cc89438dcd044c74dff4231186a065e1/
http://autobuild.buildroot.net/results/7e7/7e7e7027226bb0251e32a90df2f00d9e84aedaaf/
http://autobuild.buildroot.net/results/c18/c18e7da16121417e597a153ce7dc2a3b64ece3b0/
http://autobuild.buildroot.net/results/b29/b29e80441ed87be651d720ae2dccf24d0f7fe8b6/

Signed-off-by: Bernd Kuhls <berndkuhls@hotmail.com>
---
v2: fixed typo, shouldn´t commit patches early in the morning ;) (Yann)

 package/mtools/mtools.mk |    6 ++++++
 1 file changed, 6 insertions(+)

Comments

Yann E. MORIN March 22, 2014, 2 p.m. UTC | #1
Bernd, All,

On 2014-03-22 14:47 +0100, Bernd Kuhls spake thusly:
> Fixes
> http://autobuild.buildroot.net/results/298/298858b6cc89438dcd044c74dff4231186a065e1/
> http://autobuild.buildroot.net/results/7e7/7e7e7027226bb0251e32a90df2f00d9e84aedaaf/
> http://autobuild.buildroot.net/results/c18/c18e7da16121417e597a153ce7dc2a3b64ece3b0/
> http://autobuild.buildroot.net/results/b29/b29e80441ed87be651d720ae2dccf24d0f7fe8b6/
> 
> Signed-off-by: Bernd Kuhls <berndkuhls@hotmail.com>

Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
> v2: fixed typo, shouldn´t commit patches early in the morning ;) (Yann)
> 
>  package/mtools/mtools.mk |    6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/package/mtools/mtools.mk b/package/mtools/mtools.mk
> index 4880245..8649325 100644
> --- a/package/mtools/mtools.mk
> +++ b/package/mtools/mtools.mk
> @@ -12,5 +12,11 @@ MTOOLS_LICENSE_FILES = COPYING
>  MTOOLS_CONF_ENV = ac_cv_func_setpgrp_void=yes
>  MTOOLS_CONF_OPT = --without-x
>  
> +# link with iconv if enabled
> +ifeq ($(BR2_PACKAGE_LIBICONV),y)
> +MTOOLS_DEPENDENCIES += libiconv
> +MTOOLS_CONF_ENV += LIBS=-liconv
> +endif
> +
>  $(eval $(autotools-package))
>  $(eval $(host-autotools-package))
> -- 
> 1.7.10.4
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard March 23, 2014, 8:22 p.m. UTC | #2
>>>>> "Bernd" == Bernd Kuhls <berndkuhls@hotmail.com> writes:

 > Fixes
 > http://autobuild.buildroot.net/results/298/298858b6cc89438dcd044c74dff4231186a065e1/
 > http://autobuild.buildroot.net/results/7e7/7e7e7027226bb0251e32a90df2f00d9e84aedaaf/
 > http://autobuild.buildroot.net/results/c18/c18e7da16121417e597a153ce7dc2a3b64ece3b0/
 > http://autobuild.buildroot.net/results/b29/b29e80441ed87be651d720ae2dccf24d0f7fe8b6/

 > Signed-off-by: Bernd Kuhls <berndkuhls@hotmail.com>
 > ---
 > v2: fixed typo, shouldn´t commit patches early in the morning ;) (Yann)

Committed, thanks.
diff mbox

Patch

diff --git a/package/mtools/mtools.mk b/package/mtools/mtools.mk
index 4880245..8649325 100644
--- a/package/mtools/mtools.mk
+++ b/package/mtools/mtools.mk
@@ -12,5 +12,11 @@  MTOOLS_LICENSE_FILES = COPYING
 MTOOLS_CONF_ENV = ac_cv_func_setpgrp_void=yes
 MTOOLS_CONF_OPT = --without-x
 
+# link with iconv if enabled
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+MTOOLS_DEPENDENCIES += libiconv
+MTOOLS_CONF_ENV += LIBS=-liconv
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))