diff mbox series

[2/2] package/dahdi-linux: use package's DL_DIR

Message ID 7cf1082497a62fa2ea47b0357101efa33b453aac.1526056187.git.yann.morin.1998@free.fr
State Accepted
Headers show
Series [1/2] package/asterisk: use package's DL_DIR | expand

Commit Message

Yann E. MORIN May 11, 2018, 4:29 p.m. UTC
Sicne we reworked the download infra, the location for packages to look
for their files has moved to a per-package directory.

For systems where a download of the dahdi firmware files was already
done in a version prior to the rework, all was working fine so far,
because the files were indeed in the main DL directory.

But for systems where the download is first attempted after the rework,
the files are not found (even though they are properly downloaded).

Fix the location where dahdi-linux looks for its extra files.

Reported-by: ***** ***** <zyama.abel@mail.ru>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: ***** ***** <zyama.abel@mail.ru>
Cc: Carlos Santos <casantos@datacom.ind.br>
Cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
---
 package/dahdi-linux/dahdi-linux.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Carlos Santos May 11, 2018, 5:13 p.m. UTC | #1
> From: "Yann Morin" <yann.morin.1998@free.fr>
> To: "buildroot" <buildroot@buildroot.org>
> Cc: "Yann Morin" <yann.morin.1998@free.fr>, "***** *****" <zyama.abel@mail.ru>, "Carlos Santos"
> <casantos@datacom.ind.br>, "Maxime Hadjinlian" <maxime.hadjinlian@gmail.com>
> Sent: Friday, May 11, 2018 1:29:57 PM
> Subject: [PATCH 2/2] package/dahdi-linux: use package's DL_DIR

> Sicne we reworked the download infra, the location for packages to look

Since

[...]
diff mbox series

Patch

diff --git a/package/dahdi-linux/dahdi-linux.mk b/package/dahdi-linux/dahdi-linux.mk
index c042a14e53..6ac1e88943 100644
--- a/package/dahdi-linux/dahdi-linux.mk
+++ b/package/dahdi-linux/dahdi-linux.mk
@@ -56,7 +56,7 @@  DAHDI_LINUX_MODULE_MAKE_OPTS = \
 
 define DAHDI_LINUX_EXTRACT_FW
 	$(foreach f,$(DAHDI_LINUX_FW_FILES),\
-		cp $(BR2_DL_DIR)/$(f) $(@D)/drivers/dahdi/firmware/$(f)$(sep))
+		cp $(DAHDI_LINUX_DL_DIR)/$(f) $(@D)/drivers/dahdi/firmware/$(f)$(sep))
 endef
 DAHDI_LINUX_POST_EXTRACT_HOOKS += DAHDI_LINUX_EXTRACT_FW