diff mbox

[03/22] Remove filename extension crap for OS compatibility

Message ID 5cae11523664c212bbb8278fce0d36d79a0a0acc.1334673910.git.thomas.petazzoni@free-electrons.com
State Accepted, archived
Headers show

Commit Message

Thomas Petazzoni April 17, 2012, 2:45 p.m. UTC
The only variable that is used is HOST_LOADLIBES, defined for the
cygwin case in the kconfig build. Since we don't support cygwin,
simply get rid of this.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 Makefile |   28 ----------------------------
 1 files changed, 0 insertions(+), 28 deletions(-)

Comments

Peter Korsgaard April 19, 2012, 2:03 p.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 Thomas> The only variable that is used is HOST_LOADLIBES, defined for the
 Thomas> cygwin case in the kconfig build. Since we don't support cygwin,
 Thomas> simply get rid of this.

Committed, thanks.
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 90c2086..e03fed5 100644
--- a/Makefile
+++ b/Makefile
@@ -194,34 +194,6 @@  unexport CONFIG_SITE
 
 GNU_HOST_NAME:=$(shell support/gnuconfig/config.guess)
 
-#############################################################
-#
-# Setup the proper filename extensions for the host
-#
-##############################################################
-ifneq ($(findstring linux,$(GNU_HOST_NAME)),)
-HOST_EXEEXT:=
-HOST_LIBEXT:=.a
-HOST_SHREXT:=.so
-endif
-ifneq ($(findstring apple,$(GNU_HOST_NAME)),)
-HOST_EXEEXT:=
-HOST_LIBEXT:=.a
-HOST_SHREXT:=.dylib
-endif
-ifneq ($(findstring cygwin,$(GNU_HOST_NAME)),)
-HOST_EXEEXT:=.exe
-HOST_LIBEXT:=.lib
-HOST_SHREXT:=.dll
-HOST_LOADLIBES=-lcurses -lintl
-export HOST_LOADLIBES
-endif
-ifneq ($(findstring mingw,$(GNU_HOST_NAME)),)
-HOST_EXEEXT:=.exe
-HOST_LIBEXT:=.lib
-HOST_SHREXT:=.dll
-endif
-
 ##############################################################
 #
 # The list of stuff to build for the target toolchain