diff mbox series

[2/9,v2] package/minetest: depend on LuaJIT

Message ID 4e387bc2105a423b7085653fd368b38f383dc17c.1595881971.git.yann.morin.1998@free.fr
State Accepted
Headers show
Series [1/9,v2] package/efl: depend on LuaJIT | expand

Commit Message

Yann E. MORIN July 27, 2020, 8:32 p.m. UTC
From: James Hilliard <james.hilliard1@gmail.com>

Luajit is a provider for luainterpreter. We can't select providers of
virtual packages; we can only depend on them.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[yann.morin.1998@free.fr:
  - a lua interpreter is needed, so don't drop the dependency
  - make it a "depends on" rather than a "select"
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
---
 package/minetest/Config.in | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/package/minetest/Config.in b/package/minetest/Config.in
index 085525534d..b8ee175d52 100644
--- a/package/minetest/Config.in
+++ b/package/minetest/Config.in
@@ -5,11 +5,10 @@  config BR2_PACKAGE_MINETEST
 	depends on BR2_TOOLCHAIN_HAS_THREADS
 	depends on BR2_PACKAGE_XORG7 # irrlicht
 	depends on BR2_PACKAGE_HAS_LIBGL # irrlicht
-	depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
+	depends on BR2_PACKAGE_LUAJIT
 	select BR2_PACKAGE_IRRLICHT
 	select BR2_PACKAGE_GMP
 	select BR2_PACKAGE_JSONCPP
-	select BR2_PACKAGE_LUAJIT
 	select BR2_PACKAGE_SQLITE
 	select BR2_PACKAGE_ZLIB
 	# At least one option must be enabled
@@ -59,7 +58,6 @@  comment "minetest needs a toolchain w/ C++, gcc >= 4.9, threads"
 		|| !BR2_TOOLCHAIN_HAS_THREADS
 
 comment "minetest needs X11 and an OpenGL provider"
-	depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
 	depends on (BR2_INSTALL_LIBSTDCPP \
 		&& BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 \
 		&& BR2_TOOLCHAIN_HAS_THREADS)