diff mbox

[09/24] system: do not handle network settings for custom skeleton

Message ID 462a9abc03b184248420c3e95f6d4718e22314b9.1465766789.git.yann.morin.1998@free.fr
State Changes Requested
Headers show

Commit Message

Yann E. MORIN June 12, 2016, 9:55 p.m. UTC
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
 package/skeleton/skeleton.mk | 8 ++++----
 system/Config.in             | 5 ++---
 2 files changed, 6 insertions(+), 7 deletions(-)
diff mbox

Patch

diff --git a/package/skeleton/skeleton.mk b/package/skeleton/skeleton.mk
index 3852448..144b759 100644
--- a/package/skeleton/skeleton.mk
+++ b/package/skeleton/skeleton.mk
@@ -138,6 +138,10 @@  endef
 TARGET_FINALIZE_HOOKS += SKELETON_SET_ISSUE
 endif
 
+# The TARGET_FINALIZE_HOOKS must be sourced only if the users choose to use the
+# default skeleton.
+ifeq ($(BR2_ROOTFS_SKELETON_DEFAULT),y)
+
 define SKELETON_SET_NETWORK_LOCALHOST
 	( \
 		echo "# interface file auto-generated by buildroot"; \
@@ -171,10 +175,6 @@  endef
 
 TARGET_FINALIZE_HOOKS += SKELETON_SET_NETWORK
 
-# The TARGET_FINALIZE_HOOKS must be sourced only if the users choose to use the
-# default skeleton.
-ifeq ($(BR2_ROOTFS_SKELETON_DEFAULT),y)
-
 ifeq ($(BR2_TARGET_ENABLE_ROOT_LOGIN),y)
 ifeq ($(SKELETON_TARGET_GENERIC_ROOT_PASSWD),)
 SKELETON_ROOT_PASSWORD =
diff --git a/system/Config.in b/system/Config.in
index 662443b..c02f394 100644
--- a/system/Config.in
+++ b/system/Config.in
@@ -352,9 +352,6 @@  config BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW
 	  read-only.
 	  If unsure, say Y.
 
-endif # BR2_ROOTFS_SKELETON_DEFAULT
-
-
 config BR2_SYSTEM_DHCP
 	string "Network interface to configure through DHCP"
 	default ""
@@ -374,6 +371,8 @@  comment "automatic network configuration via DHCP is not compatible with network
 comment "automatic network configuration via DHCP needs ifupdown or busybox"
 	depends on !(BR2_PACKAGE_BUSYBOX || BR2_PACKAGE_IFUPDOWN)
 
+endif # BR2_ROOTFS_SKELETON_DEFAULT
+
 config BR2_TARGET_TZ_INFO
 	bool "Install timezone info"
 	# No timezone for musl; only for uClibc or (e)glibc.