diff mbox series

[1/1] package/augeas: bump to version 1.14.1

Message ID 20240720202231.1432128-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/augeas: bump to version 1.14.1 | expand

Commit Message

Fabrice Fontaine July 20, 2024, 8:22 p.m. UTC
This bump will fix the following build failure with gcc >= 14 thanks to
https://github.com/hercules-team/augeas/commit/792fb220a31a42043de6962fac6a1f6c030d67c5:

internal.c: In function 'xstrerror':
internal.c:436:12: error: returning 'int' from a function with return type 'const char *' makes pointer from integer without a cast [-Wint-conversion]
  436 |     return strerror_r(errnum, buf, len);
      |            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~

https://github.com/hercules-team/augeas/blob/release-1.14.1/NEWS

Fixes:
 - http://autobuild.buildroot.org/results/65014642966721115ae4050c23b083a7f39e1300

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/augeas/augeas.hash | 5 ++---
 package/augeas/augeas.mk   | 4 ++--
 2 files changed, 4 insertions(+), 5 deletions(-)

Comments

Thomas Petazzoni July 20, 2024, 9:02 p.m. UTC | #1
On Sat, 20 Jul 2024 22:22:31 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> This bump will fix the following build failure with gcc >= 14 thanks to
> https://github.com/hercules-team/augeas/commit/792fb220a31a42043de6962fac6a1f6c030d67c5:
> 
> internal.c: In function 'xstrerror':
> internal.c:436:12: error: returning 'int' from a function with return type 'const char *' makes pointer from integer without a cast [-Wint-conversion]
>   436 |     return strerror_r(errnum, buf, len);
>       |            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
> 
> https://github.com/hercules-team/augeas/blob/release-1.14.1/NEWS
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/65014642966721115ae4050c23b083a7f39e1300
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/augeas/augeas.hash | 5 ++---
>  package/augeas/augeas.mk   | 4 ++--
>  2 files changed, 4 insertions(+), 5 deletions(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 29, 2024, 6:14 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > This bump will fix the following build failure with gcc >= 14 thanks to
 > https://github.com/hercules-team/augeas/commit/792fb220a31a42043de6962fac6a1f6c030d67c5:

 > internal.c: In function 'xstrerror':
 > internal.c:436:12: error: returning 'int' from a function with return type 'const char *' makes pointer from integer without a cast [-Wint-conversion]
 >   436 |     return strerror_r(errnum, buf, len);
 >       |            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~

 > https://github.com/hercules-team/augeas/blob/release-1.14.1/NEWS

 > Fixes:
 >  - http://autobuild.buildroot.org/results/65014642966721115ae4050c23b083a7f39e1300

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2024.05.x, thanks.
diff mbox series

Patch

diff --git a/package/augeas/augeas.hash b/package/augeas/augeas.hash
index 03b71349ac..b3b2a2427c 100644
--- a/package/augeas/augeas.hash
+++ b/package/augeas/augeas.hash
@@ -1,4 +1,3 @@ 
-# Locally calculated after checking pgp signature from
-# http://download.augeas.net/augeas-1.12.0.tar.gz.sig
-sha256  321942c9cc32185e2e9cb72d0a70eea106635b50269075aca6714e3ec282cb87  augeas-1.12.0.tar.gz
+# Locally calculated
+sha256  368bfdd782e4b9c7163baadd621359c82b162734864b667051ff6bcb57b9edff  augeas-1.14.1.tar.gz
 sha256  ca0061fc1381a3ab242310e4b3f56389f28e3d460eb2fd822ed7a21c6f030532  COPYING
diff --git a/package/augeas/augeas.mk b/package/augeas/augeas.mk
index a0bc294565..ac4bc7d0be 100644
--- a/package/augeas/augeas.mk
+++ b/package/augeas/augeas.mk
@@ -4,8 +4,8 @@ 
 #
 ################################################################################
 
-AUGEAS_VERSION = 1.12.0
-AUGEAS_SITE = http://download.augeas.net
+AUGEAS_VERSION = 1.14.1
+AUGEAS_SITE = https://github.com/hercules-team/augeas/releases/download/release-$(AUGEAS_VERSION)
 AUGEAS_INSTALL_STAGING = YES
 AUGEAS_LICENSE = LGPL-2.1+
 AUGEAS_LICENSE_FILES = COPYING