diff mbox series

[1/1] package/mokutil: select libxcrypt if needed

Message ID 20240517205315.850877-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/mokutil: select libxcrypt if needed | expand

Commit Message

Fabrice Fontaine May 17, 2024, 8:53 p.m. UTC
Fix the following build failure raised since the addition of the package
in commit 2e6e121496bfcbe09c018558be13733077b6df9b:

mokutil.c:45:10: fatal error: crypt.h: No such file or directory
   45 | #include <crypt.h>
      |          ^~~~~~~~~

Fixes: 2e6e121496bfcbe09c018558be13733077b6df9b
 - http://autobuild.buildroot.org/results/59e470ad6bf7f48314cd26ed4163c095e4c803ab

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/mokutil/Config.in  | 1 +
 package/mokutil/mokutil.mk | 1 +
 2 files changed, 2 insertions(+)

Comments

Peter Korsgaard May 24, 2024, 12:33 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure raised since the addition of the package
 > in commit 2e6e121496bfcbe09c018558be13733077b6df9b:

 > mokutil.c:45:10: fatal error: crypt.h: No such file or directory
 >    45 | #include <crypt.h>
 >       |          ^~~~~~~~~

 > Fixes: 2e6e121496bfcbe09c018558be13733077b6df9b
 >  - http://autobuild.buildroot.org/results/59e470ad6bf7f48314cd26ed4163c095e4c803ab

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/mokutil/Config.in b/package/mokutil/Config.in
index 3f0c760f7d..dd02078b4e 100644
--- a/package/mokutil/Config.in
+++ b/package/mokutil/Config.in
@@ -12,6 +12,7 @@  config BR2_PACKAGE_MOKUTIL
 	depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12 # efivar
 	select BR2_PACKAGE_EFIVAR
 	select BR2_PACKAGE_KEYUTILS
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	select BR2_PACKAGE_OPENSSL
 	help
 	  mokutil is a tool to import or delete the machines owner
diff --git a/package/mokutil/mokutil.mk b/package/mokutil/mokutil.mk
index 6e83d9f138..f176fa5bee 100644
--- a/package/mokutil/mokutil.mk
+++ b/package/mokutil/mokutil.mk
@@ -14,6 +14,7 @@  MOKUTIL_DEPENDENCIES = \
 	efivar \
 	host-pkgconf \
 	keyutils \
+	$(if $(BR2_PACKAGE_LIBXCRYPT),libxcrypt) \
 	openssl
 
 $(eval $(autotools-package))