diff mbox series

[1/2] configs/openblocks_a6_defconfig: bump Linux to fix binutils 2.41 build

Message ID 20240514195019.4113851-1-peter@korsgaard.com
State Accepted
Headers show
Series [1/2] configs/openblocks_a6_defconfig: bump Linux to fix binutils 2.41 build | expand

Commit Message

Peter Korsgaard May 14, 2024, 7:50 p.m. UTC
Fixes:
https://gitlab.com/buildroot.org/buildroot/-/jobs/6813125272

The Linux kernel fails to build since commit e88225ed882 (package/binutils:
make 2.41 the default version):

arch/arm/mm/proc-feroceon.S: Assembler messages:
arch/arm/mm/proc-feroceon.S:587: Error: junk at end of line, first unrecognized character is `#'
make[3]: *** [scripts/Makefile.build:430: arch/arm/mm/proc-feroceon.o] Error 1
make[3]: *** Waiting for unfinished jobs....

Fix the build by bumping the kernel to 4.14.336, which includes commit
3ab03df64f77 (ARM: 8933/1: replace Sun/Solaris style flag on section
directive):

https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-4.14.y&id=3ab03df64f7754728a2257c47775a70a88428331

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 configs/openblocks_a6_defconfig | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN May 17, 2024, 2:36 p.m. UTC | #1
Peter, All,

On 2024-05-14 21:50 +0200, Peter Korsgaard spake thusly:
> Fixes:
> https://gitlab.com/buildroot.org/buildroot/-/jobs/6813125272
> 
> The Linux kernel fails to build since commit e88225ed882 (package/binutils:
> make 2.41 the default version):
> 
> arch/arm/mm/proc-feroceon.S: Assembler messages:
> arch/arm/mm/proc-feroceon.S:587: Error: junk at end of line, first unrecognized character is `#'
> make[3]: *** [scripts/Makefile.build:430: arch/arm/mm/proc-feroceon.o] Error 1
> make[3]: *** Waiting for unfinished jobs....
> 
> Fix the build by bumping the kernel to 4.14.336, which includes commit
> 3ab03df64f77 (ARM: 8933/1: replace Sun/Solaris style flag on section
> directive):
> 
> https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-4.14.y&id=3ab03df64f7754728a2257c47775a70a88428331
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  configs/openblocks_a6_defconfig | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/configs/openblocks_a6_defconfig b/configs/openblocks_a6_defconfig
> index 2238c0940c..69b75f5043 100644
> --- a/configs/openblocks_a6_defconfig
> +++ b/configs/openblocks_a6_defconfig
> @@ -17,7 +17,7 @@ BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_14=y
>  # kernel
>  BR2_LINUX_KERNEL=y
>  BR2_LINUX_KERNEL_CUSTOM_VERSION=y
> -BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.14.253"
> +BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.14.336"
>  BR2_LINUX_KERNEL_DEFCONFIG="mvebu_v5"
>  BR2_LINUX_KERNEL_APPENDED_UIMAGE=y
>  BR2_LINUX_KERNEL_UIMAGE_LOADADDR="0x8000"
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/configs/openblocks_a6_defconfig b/configs/openblocks_a6_defconfig
index 2238c0940c..69b75f5043 100644
--- a/configs/openblocks_a6_defconfig
+++ b/configs/openblocks_a6_defconfig
@@ -17,7 +17,7 @@  BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_14=y
 # kernel
 BR2_LINUX_KERNEL=y
 BR2_LINUX_KERNEL_CUSTOM_VERSION=y
-BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.14.253"
+BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.14.336"
 BR2_LINUX_KERNEL_DEFCONFIG="mvebu_v5"
 BR2_LINUX_KERNEL_APPENDED_UIMAGE=y
 BR2_LINUX_KERNEL_UIMAGE_LOADADDR="0x8000"