diff mbox series

[3/3] package/bmaptool: bump to version 3.8.0

Message ID 20240413131757.3627575-3-dario.binacchi@amarulasolutions.com
State Changes Requested, archived
Headers show
Series [1/3] package/bmap-tools: update GitHub URL | expand

Commit Message

Dario Binacchi April 13, 2024, 1:17 p.m. UTC
Note that, although not explicitly specified in the changelog, version
3.7 renamed the file COPYING to LICENSE, requiring corresponding changes
in Bildroot related to the license file (specifically, the name and hash).

Release notes:

- bmap-tools 3.7:
  * Use GitHub Actions for CI (#109)
  * Add `poetry` for dependency management and `black` for code
    formatting (#104)
  * Add functionality for copying from standard input (#99)
  * Switch from gpg to gpgme module (#103)

- bmaptool 3.8.0:
  * use 'df -P' for POSIX portable output
  * bmaptool has new maintainers
  * bmaptool has a new home
  * bmaptool is now only called 'bmaptool' and not one of a dozen such
    variations
  * switch to use an X.Y.Z versioning number scheme

Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
---
 package/bmaptool/bmaptool.hash | 4 ++--
 package/bmaptool/bmaptool.mk   | 6 ++++--
 2 files changed, 6 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/package/bmaptool/bmaptool.hash b/package/bmaptool/bmaptool.hash
index 9d621e76a52a..84040c948a2d 100644
--- a/package/bmaptool/bmaptool.hash
+++ b/package/bmaptool/bmaptool.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  7a2e1305bf7e06bc4a580cc719f0facf9d99af8d41659b57c0acae4ad93ff45a  bmaptool-3.6.tar.gz
-sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
+sha256  3c741ccdd5049b5cb6983bc186f7be8040a132ed7e9c2afda4d9e7390888163c  bmaptool-3.8.0.tar.gz
+sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  LICENSE
diff --git a/package/bmaptool/bmaptool.mk b/package/bmaptool/bmaptool.mk
index 34664d13b37f..fa453d4e9819 100644
--- a/package/bmaptool/bmaptool.mk
+++ b/package/bmaptool/bmaptool.mk
@@ -4,11 +4,13 @@ 
 #
 ################################################################################
 
-BMAPTOOL_VERSION = 3.6
+BMAPTOOL_VERSION = 3.8.0
 BMAPTOOL_SITE = $(call github,yoctoproject,bmaptool,v$(BMAPTOOL_VERSION))
 BMAPTOOL_LICENSE = GPL-2.0
-BMAPTOOL_LICENSE_FILES = COPYING
+BMAPTOOL_LICENSE_FILES = LICENSE
 BMAPTOOL_SETUP_TYPE = setuptools
+BMAPTOOL_DEPENDENCIES = host-python-poetry-core
+HOST_BMAPTOOL_DEPENDENCIES = host-python-poetry-core
 
 $(eval $(python-package))
 $(eval $(host-python-package))