diff mbox series

[1/1] package/vsftpd: add libxcrypt optional dependency

Message ID 20240407141247.1875759-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/vsftpd: add libxcrypt optional dependency | expand

Commit Message

Fabrice Fontaine April 7, 2024, 2:12 p.m. UTC
Fix the following build failure raised since bump of glibc to version
2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:

/home/autobuild/autobuild/instance-5/output-1/host/lib/gcc/mipsel-buildroot-linux-gnu/12.3.0/../../../../mipsel-buildroot-linux-gnu/bin/ld: cannot find -lcrypt: No such file or directory

Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
 - http://autobuild.buildroot.org/results/062dbadf1f2f8e25747f7689974a693163932113

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/vsftpd/Config.in | 1 +
 package/vsftpd/vsftpd.mk | 4 ++++
 2 files changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/package/vsftpd/Config.in b/package/vsftpd/Config.in
index 464d6f27e3..fb74b14501 100644
--- a/package/vsftpd/Config.in
+++ b/package/vsftpd/Config.in
@@ -1,6 +1,7 @@ 
 config BR2_PACKAGE_VSFTPD
 	bool "vsftpd"
 	depends on BR2_USE_MMU # fork()
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  vsftpd is an ftp daemon written with security in mind.
 	  http://vsftpd.beasts.org/
diff --git a/package/vsftpd/vsftpd.mk b/package/vsftpd/vsftpd.mk
index 6742843c19..14c1b6be13 100644
--- a/package/vsftpd/vsftpd.mk
+++ b/package/vsftpd/vsftpd.mk
@@ -35,6 +35,10 @@  VSFTPD_DEPENDENCIES += libcap
 VSFTPD_LIBS += -lcap
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
+VSFTPD_DEPENDENCIES += libxcrypt
+endif
+
 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
 VSFTPD_DEPENDENCIES += linux-pam
 VSFTPD_LIBS += -lpam