diff mbox series

[1/1] package/polkit: add libxcrypt optional dependency

Message ID 20240407134632.1838539-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/polkit: add libxcrypt optional dependency | expand

Commit Message

Fabrice Fontaine April 7, 2024, 1:46 p.m. UTC
Fix the following build failure raised since bump of glibc to version
2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:

../output-1/build/polkit-123/meson.build:267:18: ERROR: C shared or static library 'crypt' not found

Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
 - http://autobuild.buildroot.org/results/59926191d274b25e32e6bbd708f5aadb346d3171

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/polkit/Config.in | 1 +
 package/polkit/polkit.mk | 4 ++++
 2 files changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/package/polkit/Config.in b/package/polkit/Config.in
index ca3323931c..fda6c984d7 100644
--- a/package/polkit/Config.in
+++ b/package/polkit/Config.in
@@ -10,6 +10,7 @@  config BR2_PACKAGE_POLKIT
 	select BR2_PACKAGE_DUKTAPE
 	select BR2_PACKAGE_EXPAT
 	select BR2_PACKAGE_LIBGLIB2
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  PolicyKit is a toolkit for defining and handling
 	  authorizations. It is used for allowing unprivileged
diff --git a/package/polkit/polkit.mk b/package/polkit/polkit.mk
index e393672c1e..cdbbf8f9b0 100644
--- a/package/polkit/polkit.mk
+++ b/package/polkit/polkit.mk
@@ -30,6 +30,10 @@  else
 POLKIT_CONF_OPTS += -Dintrospection=false
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
+POLKIT_DEPENDENCIES += libxcrypt
+endif
+
 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
 POLKIT_DEPENDENCIES += linux-pam
 POLKIT_CONF_OPTS += -Dauthfw=pam