diff mbox series

[1/1] package/proftpd: add libxcrypt optional dependency

Message ID 20240407132516.1422205-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/proftpd: add libxcrypt optional dependency | expand

Commit Message

Fabrice Fontaine April 7, 2024, 1:25 p.m. UTC
Fix the following build failure raised since bump of glibc to version
2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:

/home/autobuild/autobuild/instance-12/output-1/host/lib/gcc/s390x-buildroot-linux-gnu/13.2.0/../../../../s390x-buildroot-linux-gnu/bin/ld: modules/mod_auth_file.o: in function `authfile_chkpass':
mod_auth_file.c:(.text+0x3aa): undefined reference to `crypt'

Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
 - http://autobuild.buildroot.org/results/4d39666854a0395e96c7b0c8339b6ac1b41c4348

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/proftpd/Config.in  | 1 +
 package/proftpd/proftpd.mk | 4 ++++
 2 files changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/package/proftpd/Config.in b/package/proftpd/Config.in
index 7b9f74895a..9d99ff70c4 100644
--- a/package/proftpd/Config.in
+++ b/package/proftpd/Config.in
@@ -2,6 +2,7 @@  config BR2_PACKAGE_PROFTPD
 	bool "proftpd"
 	depends on BR2_USE_MMU # fork()
 	depends on !BR2_STATIC_LIBS
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  ProFTPD, a highly configurable FTP server.
 
diff --git a/package/proftpd/proftpd.mk b/package/proftpd/proftpd.mk
index 0820822e17..242de38b0d 100644
--- a/package/proftpd/proftpd.mk
+++ b/package/proftpd/proftpd.mk
@@ -31,6 +31,10 @@  ifeq ($(BR2_PACKAGE_LIBIDN2),y)
 PROFTPD_DEPENDENCIES += libidn2
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
+PROFTPD_DEPENDENCIES += libxcrypt
+endif
+
 ifeq ($(BR2_PACKAGE_PCRE2),y)
 PROFTPD_CONF_OPTS += --enable-pcre2
 PROFTPD_DEPENDENCIES += pcre2