diff mbox series

[1/1] package/dante: add libxcrypt optional dependency

Message ID 20240404204241.1784136-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/dante: add libxcrypt optional dependency | expand

Commit Message

Fabrice Fontaine April 4, 2024, 8:42 p.m. UTC
Fix the following build failure raised since bump of glibc to version
2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:

/home/autobuild/autobuild/instance-5/output-1/per-package/dante/host/bin/../lib/gcc/sparc64-buildroot-linux-gnu/12.3.0/../../../../sparc64-buildroot-linux-gnu/bin/ld: auth_password.o: in function `passwordcheck':
/home/autobuild/autobuild/instance-5/output-1/build/dante-1.4.3/sockd/auth_password.c:126:(.text+0xc4): undefined reference to `crypt'

Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
 - http://autobuild.buildroot.org/results/c817caa1e9ad91a1c0f61d92f24d35612cc3a5d5

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/dante/Config.in | 1 +
 package/dante/dante.mk  | 4 ++++
 2 files changed, 5 insertions(+)

Comments

Yann E. MORIN April 7, 2024, 8:52 a.m. UTC | #1
Fabrice, All,

On 2024-04-04 22:42 +0200, Fabrice Fontaine spake thusly:
> Fix the following build failure raised since bump of glibc to version
> 2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:
> 
> /home/autobuild/autobuild/instance-5/output-1/per-package/dante/host/bin/../lib/gcc/sparc64-buildroot-linux-gnu/12.3.0/../../../../sparc64-buildroot-linux-gnu/bin/ld: auth_password.o: in function `passwordcheck':
> /home/autobuild/autobuild/instance-5/output-1/build/dante-1.4.3/sockd/auth_password.c:126:(.text+0xc4): undefined reference to `crypt'
> 
> Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
>  - http://autobuild.buildroot.org/results/c817caa1e9ad91a1c0f61d92f24d35612cc3a5d5
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/dante/Config.in | 1 +
>  package/dante/dante.mk  | 4 ++++
>  2 files changed, 5 insertions(+)
> 
> diff --git a/package/dante/Config.in b/package/dante/Config.in
> index 41a89990d2..bd0ddb236d 100644
> --- a/package/dante/Config.in
> +++ b/package/dante/Config.in
> @@ -1,6 +1,7 @@
>  config BR2_PACKAGE_DANTE
>  	bool "dante"
>  	depends on BR2_USE_MMU # fork()
> +	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
>  	help
>  	  Dante is a product developed by Inferno Nettverk A/S. It
>  	  consists of a SOCKS server and a SOCKS client, implementing
> diff --git a/package/dante/dante.mk b/package/dante/dante.mk
> index ae60252bed..bae46c5a71 100644
> --- a/package/dante/dante.mk
> +++ b/package/dante/dante.mk
> @@ -22,6 +22,10 @@ else
>  DANTE_CONF_OPTS += --without-upnp
>  endif
>  
> +ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
> +DANTE_DEPENDENCIES += libxcrypt
> +endif
> +
>  ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
>  DANTE_DEPENDENCIES += linux-pam
>  DANTE_CONF_OPTS += --with-pam
> -- 
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/dante/Config.in b/package/dante/Config.in
index 41a89990d2..bd0ddb236d 100644
--- a/package/dante/Config.in
+++ b/package/dante/Config.in
@@ -1,6 +1,7 @@ 
 config BR2_PACKAGE_DANTE
 	bool "dante"
 	depends on BR2_USE_MMU # fork()
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  Dante is a product developed by Inferno Nettverk A/S. It
 	  consists of a SOCKS server and a SOCKS client, implementing
diff --git a/package/dante/dante.mk b/package/dante/dante.mk
index ae60252bed..bae46c5a71 100644
--- a/package/dante/dante.mk
+++ b/package/dante/dante.mk
@@ -22,6 +22,10 @@  else
 DANTE_CONF_OPTS += --without-upnp
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
+DANTE_DEPENDENCIES += libxcrypt
+endif
+
 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
 DANTE_DEPENDENCIES += linux-pam
 DANTE_CONF_OPTS += --with-pam