diff mbox series

[v2,3/3] uboot/uboot: add new dependency to yamllint

Message ID 20240404081714.1190807-3-heiko.thiery@gmail.com
State Changes Requested
Headers show
Series [v2,1/3] package/python-yamllint: new package | expand

Commit Message

Heiko Thiery April 4, 2024, 8:17 a.m. UTC
Since U-Boot 2024.04 [1] binman also uses yamllint as dependency [2].

[1] https://source.denx.de/u-boot/u-boot/-/commit/10fee88d42f
[2] https://source.denx.de/u-boot/u-boot/-/blob/v2024.04/tools/buildman/requirements.txt?ref_type=tags#L3

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
 boot/uboot/uboot.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Romain Naour April 10, 2024, 10:06 p.m. UTC | #1
Hello Heiko,

Le 04/04/2024 à 10:17, Heiko Thiery a écrit :
> Since U-Boot 2024.04 [1] binman also uses yamllint as dependency [2].
> 
> [1] https://source.denx.de/u-boot/u-boot/-/commit/10fee88d42f
> [2] https://source.denx.de/u-boot/u-boot/-/blob/v2024.04/tools/buildman/requirements.txt?ref_type=tags#L3

Same comment as for ti-k3-r5-loader.

The second url is missing in the comment. Maybe you can add it?

Best regards,
Romain


> 
> Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
> ---
>  boot/uboot/uboot.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
> index 14502d4db2..26b9afdb00 100644
> --- a/boot/uboot/uboot.mk
> +++ b/boot/uboot/uboot.mk
> @@ -279,7 +279,8 @@ ifeq ($(BR2_TARGET_UBOOT_USE_BINMAN),y)
>  # https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/buildman/requirements.txt
>  UBOOT_DEPENDENCIES += \
>  	host-python-jsonschema \
> -	host-python-pyyaml
> +	host-python-pyyaml \
> +	host-python-yamllint
>  UBOOT_MAKE_OPTS += BINMAN_INDIRS=$(BINARIES_DIR)
>  endif
>
diff mbox series

Patch

diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 14502d4db2..26b9afdb00 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -279,7 +279,8 @@  ifeq ($(BR2_TARGET_UBOOT_USE_BINMAN),y)
 # https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/buildman/requirements.txt
 UBOOT_DEPENDENCIES += \
 	host-python-jsonschema \
-	host-python-pyyaml
+	host-python-pyyaml \
+	host-python-yamllint
 UBOOT_MAKE_OPTS += BINMAN_INDIRS=$(BINARIES_DIR)
 endif