diff mbox series

[v2,1/1] package/osm2pgsql: only supports 64 bits

Message ID 20240317220028.1497643-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v2,1/1] package/osm2pgsql: only supports 64 bits | expand

Commit Message

Fabrice Fontaine March 17, 2024, 10 p.m. UTC
osm2pgsql only supports 64 bits architectures since bump to version
1.10.0 in commit e056aeeca9cf8c00c6da62c39979ce6c55c92791 and
https://github.com/osm2pgsql-dev/osm2pgsql/commit/389904269a1b1f246641d203abadfcd5cebb97cc
resulting in the following build failure with arm:

CMake Error at CMakeLists.txt:20 (message):
  osm2pgsql needs a 64 bit architecture

Fixes: e056aeeca9cf8c00c6da62c39979ce6c55c92791
 - http://autobuild.buildroot.org/results/30c2675a732fd810c68dffbb6483f9cf8e4fcbf3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2 (after review of Arnout Vandecappelle):
 - Use BR2_ARCH_IS_64

 package/osm2pgsql/Config.in | 3 +++
 1 file changed, 3 insertions(+)

Comments

Maxim Kochetkov March 18, 2024, 4:58 a.m. UTC | #1
18.03.2024 01:00, Fabrice Fontaine пишет:
> osm2pgsql only supports 64 bits architectures since bump to version
> 1.10.0 in commit e056aeeca9cf8c00c6da62c39979ce6c55c92791 and
> https://github.com/osm2pgsql-dev/osm2pgsql/commit/389904269a1b1f246641d203abadfcd5cebb97cc
> resulting in the following build failure with arm:
> 
> CMake Error at CMakeLists.txt:20 (message):
>    osm2pgsql needs a 64 bit architecture
> 
> Fixes: e056aeeca9cf8c00c6da62c39979ce6c55c92791
>   - http://autobuild.buildroot.org/results/30c2675a732fd810c68dffbb6483f9cf8e4fcbf3
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Reviewed-by: Maxim Kochetkov <fido_max@inbox.ru>
Arnout Vandecappelle March 20, 2024, 8:31 p.m. UTC | #2
On 17/03/2024 23:00, Fabrice Fontaine wrote:
> osm2pgsql only supports 64 bits architectures since bump to version
> 1.10.0 in commit e056aeeca9cf8c00c6da62c39979ce6c55c92791 and
> https://github.com/osm2pgsql-dev/osm2pgsql/commit/389904269a1b1f246641d203abadfcd5cebb97cc
> resulting in the following build failure with arm:
> 
> CMake Error at CMakeLists.txt:20 (message):
>    osm2pgsql needs a 64 bit architecture
> 
> Fixes: e056aeeca9cf8c00c6da62c39979ce6c55c92791
>   - http://autobuild.buildroot.org/results/30c2675a732fd810c68dffbb6483f9cf8e4fcbf3
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
> Changes v1 -> v2 (after review of Arnout Vandecappelle):
>   - Use BR2_ARCH_IS_64
> 
>   package/osm2pgsql/Config.in | 3 +++
>   1 file changed, 3 insertions(+)
> 
> diff --git a/package/osm2pgsql/Config.in b/package/osm2pgsql/Config.in
> index c6a38f3180..439309df95 100644
> --- a/package/osm2pgsql/Config.in
> +++ b/package/osm2pgsql/Config.in
> @@ -1,5 +1,6 @@
>   config BR2_PACKAGE_OSM2PGSQL
>   	bool "osm2pgsql"
> +	depends on BR2_ARCH_IS_64
>   	depends on BR2_INSTALL_LIBSTDCPP # boost, libosmium, protozero
>   	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C++14
>   	depends on BR2_TOOLCHAIN_HAS_THREADS # boost, libosmium
> @@ -24,9 +25,11 @@ config BR2_PACKAGE_OSM2PGSQL
>   	  https://osm2pgsql.org
>   
>   comment "osm2pgsql needs a toolchain w/ C++, wchar, threads, gcc >= 4.9"
> +	depends on BR2_ARCH_IS_64
>   	depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS
>   	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
>   		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || !BR2_TOOLCHAIN_HAS_THREADS
>   
>   comment "osm2pgsql needs a toolchain not affected by GCC bug 64735"
> +	depends on BR2_ARCH_IS_64
>   	depends on BR2_TOOLCHAIN_HAS_GCC_BUG_64735
Peter Korsgaard March 23, 2024, 12:12 p.m. UTC | #3
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > osm2pgsql only supports 64 bits architectures since bump to version
 > 1.10.0 in commit e056aeeca9cf8c00c6da62c39979ce6c55c92791 and
 > https://github.com/osm2pgsql-dev/osm2pgsql/commit/389904269a1b1f246641d203abadfcd5cebb97cc
 > resulting in the following build failure with arm:

 > CMake Error at CMakeLists.txt:20 (message):
 >   osm2pgsql needs a 64 bit architecture

 > Fixes: e056aeeca9cf8c00c6da62c39979ce6c55c92791
 >  - http://autobuild.buildroot.org/results/30c2675a732fd810c68dffbb6483f9cf8e4fcbf3

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 > ---
 > Changes v1 -> v2 (after review of Arnout Vandecappelle):
 >  - Use BR2_ARCH_IS_64

Committed to 2024.02.x, thanks.
diff mbox series

Patch

diff --git a/package/osm2pgsql/Config.in b/package/osm2pgsql/Config.in
index c6a38f3180..439309df95 100644
--- a/package/osm2pgsql/Config.in
+++ b/package/osm2pgsql/Config.in
@@ -1,5 +1,6 @@ 
 config BR2_PACKAGE_OSM2PGSQL
 	bool "osm2pgsql"
+	depends on BR2_ARCH_IS_64
 	depends on BR2_INSTALL_LIBSTDCPP # boost, libosmium, protozero
 	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C++14
 	depends on BR2_TOOLCHAIN_HAS_THREADS # boost, libosmium
@@ -24,9 +25,11 @@  config BR2_PACKAGE_OSM2PGSQL
 	  https://osm2pgsql.org
 
 comment "osm2pgsql needs a toolchain w/ C++, wchar, threads, gcc >= 4.9"
+	depends on BR2_ARCH_IS_64
 	depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS
 	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
 		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || !BR2_TOOLCHAIN_HAS_THREADS
 
 comment "osm2pgsql needs a toolchain not affected by GCC bug 64735"
+	depends on BR2_ARCH_IS_64
 	depends on BR2_TOOLCHAIN_HAS_GCC_BUG_64735