diff mbox series

[1/1] package/libunwind: fix libucontext handling

Message ID 20240317105529.253562-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/libunwind: fix libucontext handling | expand

Commit Message

Fabrice Fontaine March 17, 2024, 10:55 a.m. UTC
Commit 6ea2a27f9047696ce1c463ad55fb4a78df136954 forgot to add -lucontext
to LIBS resulting in the following build failure with zeromq:

/home/buildroot/instance-0/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i586-buildroot-linux-musl/9.3.0/../../../../i586-buildroot-linux-musl/bin/ld: /home/buildroot/instance-0/output-1/host/i586-buildroot-linux-musl/sysroot/usr/lib32/libunwind.so.8: undefined reference to `setcontext'

Fixes: 6ea2a27f9047696ce1c463ad55fb4a78df136954
 - http://autobuild.buildroot.org/results/893defe1588b2ca03c115b59b47be3f4aed438fb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libunwind/libunwind.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Arnout Vandecappelle March 24, 2024, 4:53 p.m. UTC | #1
On 17/03/2024 11:55, Fabrice Fontaine wrote:
> Commit 6ea2a27f9047696ce1c463ad55fb4a78df136954 forgot to add -lucontext
> to LIBS resulting in the following build failure with zeromq:
> 
> /home/buildroot/instance-0/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i586-buildroot-linux-musl/9.3.0/../../../../i586-buildroot-linux-musl/bin/ld: /home/buildroot/instance-0/output-1/host/i586-buildroot-linux-musl/sysroot/usr/lib32/libunwind.so.8: undefined reference to `setcontext'
> 
> Fixes: 6ea2a27f9047696ce1c463ad55fb4a78df136954
>   - http://autobuild.buildroot.org/results/893defe1588b2ca03c115b59b47be3f4aed438fb
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/libunwind/libunwind.mk | 1 +
>   1 file changed, 1 insertion(+)
> 
> diff --git a/package/libunwind/libunwind.mk b/package/libunwind/libunwind.mk
> index 15c4e4863f..94e9bbd1b8 100644
> --- a/package/libunwind/libunwind.mk
> +++ b/package/libunwind/libunwind.mk
> @@ -17,6 +17,7 @@ LIBUNWIND_CONF_OPTS = \
>   
>   ifeq ($(BR2_PACKAGE_LIBUCONTEXT),y)
>   LIBUNWIND_DEPENDENCIES += libucontext
> +LIBUNWIND_CONF_OPTS += LIBS=-lucontext
>   endif
>   
>   $(eval $(autotools-package))
Peter Korsgaard March 25, 2024, 6:09 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Commit 6ea2a27f9047696ce1c463ad55fb4a78df136954 forgot to add -lucontext
 > to LIBS resulting in the following build failure with zeromq:

 > /home/buildroot/instance-0/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i586-buildroot-linux-musl/9.3.0/../../../../i586-buildroot-linux-musl/bin/ld:
 > /home/buildroot/instance-0/output-1/host/i586-buildroot-linux-musl/sysroot/usr/lib32/libunwind.so.8:
 > undefined reference to `setcontext'

 > Fixes: 6ea2a27f9047696ce1c463ad55fb4a78df136954
 >  - http://autobuild.buildroot.org/results/893defe1588b2ca03c115b59b47be3f4aed438fb

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2024.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/libunwind/libunwind.mk b/package/libunwind/libunwind.mk
index 15c4e4863f..94e9bbd1b8 100644
--- a/package/libunwind/libunwind.mk
+++ b/package/libunwind/libunwind.mk
@@ -17,6 +17,7 @@  LIBUNWIND_CONF_OPTS = \
 
 ifeq ($(BR2_PACKAGE_LIBUCONTEXT),y)
 LIBUNWIND_DEPENDENCIES += libucontext
+LIBUNWIND_CONF_OPTS += LIBS=-lucontext
 endif
 
 $(eval $(autotools-package))