diff mbox series

package/targetcli-fb: needs python-gobject

Message ID 20240312011317.1956535-1-jeremy@jeremypeper.com
State Superseded
Headers show
Series package/targetcli-fb: needs python-gobject | expand

Commit Message

Jeremy J. Peper March 12, 2024, 1:13 a.m. UTC
add python-gobject to resolve "ModuleNotFoundError: No module named 'gi'" error encountered if built without it.

Signed-off-by: Jeremy J. Peper <jeremy@jeremypeper.com>
---
 package/targetcli-fb/Config.in       | 1 +
 package/targetcli-fb/targetcli-fb.mk | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Adam Duskett March 12, 2024, 6:40 p.m. UTC | #1
Hello!

Thank you so much for the patch! It's really appreciated! There is one
issue to bring
up that will require you to send a v2 of this patch. Nothing too bad,
just an oversight
I am sure! See below:


On Mon, Mar 11, 2024 at 6:13 PM Jeremy J. Peper <jeremy@jeremypeper.com> wrote:
>
> add python-gobject to resolve "ModuleNotFoundError: No module named 'gi'" error encountered if built without it.
>
> Signed-off-by: Jeremy J. Peper <jeremy@jeremypeper.com>
> ---
>  package/targetcli-fb/Config.in       | 1 +
>  package/targetcli-fb/targetcli-fb.mk | 2 +-
>  2 files changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/package/targetcli-fb/Config.in b/package/targetcli-fb/Config.in
> index 04c6a1ac..722b9400 100644
> --- a/package/targetcli-fb/Config.in
> +++ b/package/targetcli-fb/Config.in
> @@ -7,6 +7,7 @@ config BR2_PACKAGE_TARGETCLI_FB
>         select BR2_PACKAGE_PYTHON_CONFIGSHELL_FB
>         select BR2_PACKAGE_PYTHON_RTSLIB_FB
>         select BR2_PACKAGE_PYTHON_SIX
> +       select BR2_PACKAGE_PYTHON_GOBJECT
Selecting and depending on python-gobject is great! But you also need to add
python-gobjects dependencies to targetcli-fb. Luckily, there are no packages
that currently depend on or select targetcli-fb, so no dependencies need to be
propagated further than this package!

Thanks so much!
Adam

>         help
>           targetcli-fb is a command-line interface for configuring the
>           LIO generic SCSI target, present in 3.x Linux kernel
> diff --git a/package/targetcli-fb/targetcli-fb.mk b/package/targetcli-fb/targetcli-fb.mk
> index d2cbf79e..dbe36e59 100644
> --- a/package/targetcli-fb/targetcli-fb.mk
> +++ b/package/targetcli-fb/targetcli-fb.mk
> @@ -12,7 +12,7 @@ TARGETCLI_FB_LICENSE = Apache-2.0
>  TARGETCLI_FB_LICENSE_FILES = COPYING
>  TARGETCLI_FB_CPE_ID_VALID = YES
>  TARGETCLI_FB_SETUP_TYPE = setuptools
> -TARGETCLI_FB_DEPENDENCIES = python-configshell-fb python-rtslib-fb python-six
> +TARGETCLI_FB_DEPENDENCIES = python-configshell-fb python-rtslib-fb python-six python-gobject
>
>  define TARGETCLI_FB_INSTALL_INIT_SYSV
>         $(INSTALL) -m 0755 -D package/targetcli-fb/S50target \
> --
> 2.39.2
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/targetcli-fb/Config.in b/package/targetcli-fb/Config.in
index 04c6a1ac..722b9400 100644
--- a/package/targetcli-fb/Config.in
+++ b/package/targetcli-fb/Config.in
@@ -7,6 +7,7 @@  config BR2_PACKAGE_TARGETCLI_FB
 	select BR2_PACKAGE_PYTHON_CONFIGSHELL_FB
 	select BR2_PACKAGE_PYTHON_RTSLIB_FB
 	select BR2_PACKAGE_PYTHON_SIX
+	select BR2_PACKAGE_PYTHON_GOBJECT
 	help
 	  targetcli-fb is a command-line interface for configuring the
 	  LIO generic SCSI target, present in 3.x Linux kernel
diff --git a/package/targetcli-fb/targetcli-fb.mk b/package/targetcli-fb/targetcli-fb.mk
index d2cbf79e..dbe36e59 100644
--- a/package/targetcli-fb/targetcli-fb.mk
+++ b/package/targetcli-fb/targetcli-fb.mk
@@ -12,7 +12,7 @@  TARGETCLI_FB_LICENSE = Apache-2.0
 TARGETCLI_FB_LICENSE_FILES = COPYING
 TARGETCLI_FB_CPE_ID_VALID = YES
 TARGETCLI_FB_SETUP_TYPE = setuptools
-TARGETCLI_FB_DEPENDENCIES = python-configshell-fb python-rtslib-fb python-six
+TARGETCLI_FB_DEPENDENCIES = python-configshell-fb python-rtslib-fb python-six python-gobject
 
 define TARGETCLI_FB_INSTALL_INIT_SYSV
 	$(INSTALL) -m 0755 -D package/targetcli-fb/S50target \