diff mbox series

[1/1] package/rauc-hawkbit-updater: fix build with gcc 4.8

Message ID 20240304155009.3505542-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/rauc-hawkbit-updater: fix build with gcc 4.8 | expand

Commit Message

Fabrice Fontaine March 4, 2024, 3:50 p.m. UTC
Fix the following build failure with gcc 4.8 raised since the addition
of the package in commit 928b7219cd7079864eadadc66dbff21c5cd72804:

../src/hawkbit-client.c:873:17: error: 'for' loop initial declarations are only allowed in C99 mode
                 for (const gint *code = &resumable_codes[0]; *code; code++)
                 ^
../src/hawkbit-client.c:873:17: note: use option -std=c99 or -std=gnu99 to compile your code

Fixes: 928b7219cd7079864eadadc66dbff21c5cd72804
 - http://autobuild.buildroot.org/results/e275d0ec4fe1da418a6163b46666316034b83b19

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/rauc-hawkbit-updater/rauc-hawkbit-updater.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Peter Korsgaard March 4, 2024, 9:48 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure with gcc 4.8 raised since the addition
 > of the package in commit 928b7219cd7079864eadadc66dbff21c5cd72804:

 > ../src/hawkbit-client.c:873:17: error: 'for' loop initial declarations are only allowed in C99 mode
 >                  for (const gint *code = &resumable_codes[0]; *code; code++)
 >                  ^
 > ../src/hawkbit-client.c:873:17: note: use option -std=c99 or -std=gnu99 to compile your code

 > Fixes: 928b7219cd7079864eadadc66dbff21c5cd72804
 >  - http://autobuild.buildroot.org/results/e275d0ec4fe1da418a6163b46666316034b83b19

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard March 19, 2024, 4:33 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure with gcc 4.8 raised since the addition
 > of the package in commit 928b7219cd7079864eadadc66dbff21c5cd72804:

 > ../src/hawkbit-client.c:873:17: error: 'for' loop initial declarations are only allowed in C99 mode
 >                  for (const gint *code = &resumable_codes[0]; *code; code++)
 >                  ^
 > ../src/hawkbit-client.c:873:17: note: use option -std=c99 or -std=gnu99 to compile your code

 > Fixes: 928b7219cd7079864eadadc66dbff21c5cd72804
 >  - http://autobuild.buildroot.org/results/e275d0ec4fe1da418a6163b46666316034b83b19

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/rauc-hawkbit-updater/rauc-hawkbit-updater.mk b/package/rauc-hawkbit-updater/rauc-hawkbit-updater.mk
index a453f75a28..3836d3c84e 100644
--- a/package/rauc-hawkbit-updater/rauc-hawkbit-updater.mk
+++ b/package/rauc-hawkbit-updater/rauc-hawkbit-updater.mk
@@ -10,5 +10,6 @@  RAUC_HAWKBIT_UPDATER_SOURCE = rauc-hawkbit-updater-$(RAUC_HAWKBIT_UPDATER_VERSIO
 RAUC_HAWKBIT_UPDATER_LICENSE = LGPL-2.1
 RAUC_HAWKBIT_UPDATER_LICENSE_FILES = LICENSE
 RAUC_HAWKBIT_UPDATER_DEPENDENCIES = json-glib libcurl
+RAUC_HAWKBIT_UPDATER_CFLAGS = $(TARGET_CFLAGS) -std=c99
 
 $(eval $(meson-package))