diff mbox series

[1/1] package/conmon: fix build with gcc 4.8

Message ID 20240303100626.120767-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/conmon: fix build with gcc 4.8 | expand

Commit Message

Fabrice Fontaine March 3, 2024, 10:06 a.m. UTC
Fix the following build failure with gcc 4.8 raised since the addition
of the package in commit 06f50ff1bf066feb6cf6ed512113773f87c884fb:

src/conmon.c:5:2: error: #error conmon.c requires C99 or later
 #error conmon.c requires C99 or later
  ^

Fixes: 06f50ff1bf066feb6cf6ed512113773f87c884fb
 - http://autobuild.buildroot.org/results/b573aceefde04435ea13dfd2a48f9c2372bde4d7

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/conmon/conmon.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard March 3, 2024, 12:27 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure with gcc 4.8 raised since the addition
 > of the package in commit 06f50ff1bf066feb6cf6ed512113773f87c884fb:

 > src/conmon.c:5:2: error: #error conmon.c requires C99 or later
 >  #error conmon.c requires C99 or later
 >   ^

 > Fixes: 06f50ff1bf066feb6cf6ed512113773f87c884fb
 >  - http://autobuild.buildroot.org/results/b573aceefde04435ea13dfd2a48f9c2372bde4d7

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard March 19, 2024, 12:08 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure with gcc 4.8 raised since the addition
 > of the package in commit 06f50ff1bf066feb6cf6ed512113773f87c884fb:

 > src/conmon.c:5:2: error: #error conmon.c requires C99 or later
 >  #error conmon.c requires C99 or later
 >   ^

 > Fixes: 06f50ff1bf066feb6cf6ed512113773f87c884fb
 >  - http://autobuild.buildroot.org/results/b573aceefde04435ea13dfd2a48f9c2372bde4d7

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/conmon/conmon.mk b/package/conmon/conmon.mk
index 214cb460a5..1e57786686 100644
--- a/package/conmon/conmon.mk
+++ b/package/conmon/conmon.mk
@@ -25,7 +25,8 @@  define CONMON_CONFIGURE_CMDS
 endef
 
 define CONMON_BUILD_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+	$(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" \
+		CFLAGS="$(TARGET_CFLAGS) -std=c99" \
 		LDFLAGS="$(TARGET_LDFLAGS)" -C $(@D) bin/conmon
 endef