diff mbox series

[1/1] package/gstreamer1/gst1-plugins-good: switch to libsoup3

Message ID 20231227114823.1167238-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/gstreamer1/gst1-plugins-good: switch to libsoup3 | expand

Commit Message

Fabrice Fontaine Dec. 27, 2023, 11:48 a.m. UTC
libsoup3 is supported since
https://gitlab.freedesktop.org/gstreamer/gstreamer/-/commit/c3455def2e7bd09a7c3806283ceb69d0bef24869

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gstreamer1/gst1-plugins-good/Config.in         | 10 +++++-----
 .../gstreamer1/gst1-plugins-good/gst1-plugins-good.mk  |  4 ++--
 2 files changed, 7 insertions(+), 7 deletions(-)

Comments

Peter Korsgaard Dec. 27, 2023, 7:21 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > libsoup3 is supported since
 > https://gitlab.freedesktop.org/gstreamer/gstreamer/-/commit/c3455def2e7bd09a7c3806283ceb69d0bef24869

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

It looks like that commit makes it work with either libsoup or libsoup3,
but OK - Probably not worth the trouble.

Committed, thanks.
diff mbox series

Patch

diff --git a/package/gstreamer1/gst1-plugins-good/Config.in b/package/gstreamer1/gst1-plugins-good/Config.in
index 36a542227a..e1e2674a4a 100644
--- a/package/gstreamer1/gst1-plugins-good/Config.in
+++ b/package/gstreamer1/gst1-plugins-good/Config.in
@@ -261,7 +261,7 @@  comment "plugins with external dependencies"
 config BR2_PACKAGE_GST1_PLUGINS_GOOD_ADAPTIVEMUX2
 	bool "adaptivedemux2 (Adaptive Streaming 2)"
 	select BR2_PACKAGE_LIBXML2
-	select BR2_PACKAGE_LIBSOUP
+	select BR2_PACKAGE_LIBSOUP3
 
 config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_LAME
 	bool "lame (*.mp3 audio encoder)"
@@ -383,11 +383,11 @@  comment "pulseaudio support needs a toolchain w/ threads, wchar, dynamic library
 
 config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_SOUPHTTPSRC
 	bool "souphttpsrc (http client)"
-	depends on BR2_USE_WCHAR # libsoup -> glib2
-	depends on BR2_TOOLCHAIN_HAS_THREADS # libsoup -> glib2
-	select BR2_PACKAGE_LIBSOUP
+	depends on BR2_USE_WCHAR # libsoup3 -> glib2
+	depends on BR2_TOOLCHAIN_HAS_THREADS # libsoup3 -> glib2
+	select BR2_PACKAGE_LIBSOUP3
 	help
-	  libsoup HTTP client src/sink
+	  libsoup3 HTTP client src/sink
 
 comment "souphttpsrc needs a toolchain w/ wchar, threads"
 	depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk b/package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk
index 4a84ea01b9..d1a0d71dfb 100644
--- a/package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk
+++ b/package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk
@@ -60,7 +60,7 @@  endif
 
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_GOOD_ADAPTIVEMUX2),y)
 GST1_PLUGINS_GOOD_CONF_OPTS += -Dadaptivedemux2=enabled
-GST1_PLUGINS_GOOD_DEPENDENCIES += libsoup libxml2
+GST1_PLUGINS_GOOD_DEPENDENCIES += libsoup3 libxml2
 else
 GST1_PLUGINS_GOOD_CONF_OPTS += -Dadaptivedemux2=disabled
 endif
@@ -453,7 +453,7 @@  endif
 
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_SOUPHTTPSRC),y)
 GST1_PLUGINS_GOOD_CONF_OPTS += -Dsoup=enabled
-GST1_PLUGINS_GOOD_DEPENDENCIES += libsoup
+GST1_PLUGINS_GOOD_DEPENDENCIES += libsoup3
 else
 GST1_PLUGINS_GOOD_CONF_OPTS += -Dsoup=disabled
 endif