diff mbox series

[v2,18/24] package/python-pyxb: Drop package

Message ID 20231105202555.359391-18-adam.duskett@amarulasolutions.com
State Accepted
Headers show
Series [v2,01/24] package/python3: use upstream build system to disable berkeleydb module | expand

Commit Message

Adam Duskett Nov. 5, 2023, 8:25 p.m. UTC
The last time python-pyxb was updated according to pypi.org is in 2017.
As there are no maintainers listed for the package, and the package uses
distutils which has been removed in Python 3.12.0, remove the package.

Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>
---
v1 -> v2: Drop the Config option for python-pyxb in this patch.

 Config.in.legacy                     |  7 +++++++
 package/Config.in                    |  1 -
 package/python-pyxb/Config.in        |  8 --------
 package/python-pyxb/python-pyxb.hash |  4 ----
 package/python-pyxb/python-pyxb.mk   | 14 --------------
 5 files changed, 7 insertions(+), 27 deletions(-)
 delete mode 100644 package/python-pyxb/Config.in
 delete mode 100644 package/python-pyxb/python-pyxb.hash
 delete mode 100644 package/python-pyxb/python-pyxb.mk

Comments

Arnout Vandecappelle Nov. 10, 2023, 8:58 p.m. UTC | #1
On 05/11/2023 21:25, Adam Duskett wrote:
> The last time python-pyxb was updated according to pypi.org is in 2017.
> As there are no maintainers listed for the package, and the package uses
> distutils which has been removed in Python 3.12.0, remove the package.

  It seems there was a mistake here...

- James is listed as a developer (with wildcard).
- James submitted a patch on Oct 1 (long before the first attempt to bump to 
3.12.0) to switch to setuptools [1].

  That said, I don't think anyone will actually miss pyxb...

  Regards,
  Arnout

[1] 
https://patchwork.ozlabs.org/project/buildroot/patch/20231001091943.1772441-1-james.hilliard1@gmail.com/



> 
> Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>
> ---
> v1 -> v2: Drop the Config option for python-pyxb in this patch.
> 
>   Config.in.legacy                     |  7 +++++++
>   package/Config.in                    |  1 -
>   package/python-pyxb/Config.in        |  8 --------
>   package/python-pyxb/python-pyxb.hash |  4 ----
>   package/python-pyxb/python-pyxb.mk   | 14 --------------
>   5 files changed, 7 insertions(+), 27 deletions(-)
>   delete mode 100644 package/python-pyxb/Config.in
>   delete mode 100644 package/python-pyxb/python-pyxb.hash
>   delete mode 100644 package/python-pyxb/python-pyxb.mk
> 
> diff --git a/Config.in.legacy b/Config.in.legacy
> index 6fef2318b0..312d53943c 100644
> --- a/Config.in.legacy
> +++ b/Config.in.legacy
> @@ -146,6 +146,13 @@ endif
>   
>   comment "Legacy options removed in 2023.11"
>   
> +config BR2_PACKAGE_PYTHON_PYXB
> +	bool "python-pyxb removed"
> +	select BR2_LEGACY
> +	help
> +	  python-pyxb has been removed due to being abandoned and
> +	  distutils no longer being supported in python 3.12.0.
> +
>   config BR2_PACKAGE_OPENJDK_VERSION_11
>   	bool "openjdk 11 has been removed"
>   	select BR2_LEGACY
> diff --git a/package/Config.in b/package/Config.in
> index a0d5339b0a..32347fe4e8 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -1268,7 +1268,6 @@ menu "External python modules"
>   	source "package/python-pytz/Config.in"
>   	source "package/python-pyudev/Config.in"
>   	source "package/python-pyusb/Config.in"
> -	source "package/python-pyxb/Config.in"
>   	source "package/python-pyyaml/Config.in"
>   	source "package/python-pyzmq/Config.in"
>   	source "package/python-qrcode/Config.in"
> diff --git a/package/python-pyxb/Config.in b/package/python-pyxb/Config.in
> deleted file mode 100644
> index 6555ed80b6..0000000000
> --- a/package/python-pyxb/Config.in
> +++ /dev/null
> @@ -1,8 +0,0 @@
> -config BR2_PACKAGE_PYTHON_PYXB
> -	bool "python-pyxb"
> -	help
> -	  PyXB is a pure Python package that generates Python code for
> -	  classes that correspond to data structures defined by
> -	  XMLSchema.
> -
> -	  http://pyxb.sourceforge.net/
> diff --git a/package/python-pyxb/python-pyxb.hash b/package/python-pyxb/python-pyxb.hash
> deleted file mode 100644
> index f24cd42e5a..0000000000
> --- a/package/python-pyxb/python-pyxb.hash
> +++ /dev/null
> @@ -1,4 +0,0 @@
> -# md5 from https://pypi.python.org/pypi/PyXB/json, sha256 locally computed
> -md5  4303573fc7094ce4664c5b71cd4bdb48  PyXB-1.2.6.tar.gz
> -sha256  2a00f38dd1d87b88f92d79bc5a09718d730419b88e814545f472bbd5a3bf27b4  PyXB-1.2.6.tar.gz
> -sha256  cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30  LICENSE
> diff --git a/package/python-pyxb/python-pyxb.mk b/package/python-pyxb/python-pyxb.mk
> deleted file mode 100644
> index 6af10b51e7..0000000000
> --- a/package/python-pyxb/python-pyxb.mk
> +++ /dev/null
> @@ -1,14 +0,0 @@
> -################################################################################
> -#
> -# python-pyxb
> -#
> -################################################################################
> -
> -PYTHON_PYXB_VERSION = 1.2.6
> -PYTHON_PYXB_SOURCE = PyXB-$(PYTHON_PYXB_VERSION).tar.gz
> -PYTHON_PYXB_SITE = https://pypi.python.org/packages/e3/09/4fdb190ea2b7cb43d6d3e745276ee69f4d6181be70fcbfda7df3c5f72f0e
> -PYTHON_PYXB_LICENSE = Apache-2.0
> -PYTHON_PYXB_LICENSE_FILES = LICENSE
> -PYTHON_PYXB_SETUP_TYPE = distutils
> -
> -$(eval $(python-package))
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index 6fef2318b0..312d53943c 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -146,6 +146,13 @@  endif
 
 comment "Legacy options removed in 2023.11"
 
+config BR2_PACKAGE_PYTHON_PYXB
+	bool "python-pyxb removed"
+	select BR2_LEGACY
+	help
+	  python-pyxb has been removed due to being abandoned and
+	  distutils no longer being supported in python 3.12.0.
+
 config BR2_PACKAGE_OPENJDK_VERSION_11
 	bool "openjdk 11 has been removed"
 	select BR2_LEGACY
diff --git a/package/Config.in b/package/Config.in
index a0d5339b0a..32347fe4e8 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1268,7 +1268,6 @@  menu "External python modules"
 	source "package/python-pytz/Config.in"
 	source "package/python-pyudev/Config.in"
 	source "package/python-pyusb/Config.in"
-	source "package/python-pyxb/Config.in"
 	source "package/python-pyyaml/Config.in"
 	source "package/python-pyzmq/Config.in"
 	source "package/python-qrcode/Config.in"
diff --git a/package/python-pyxb/Config.in b/package/python-pyxb/Config.in
deleted file mode 100644
index 6555ed80b6..0000000000
--- a/package/python-pyxb/Config.in
+++ /dev/null
@@ -1,8 +0,0 @@ 
-config BR2_PACKAGE_PYTHON_PYXB
-	bool "python-pyxb"
-	help
-	  PyXB is a pure Python package that generates Python code for
-	  classes that correspond to data structures defined by
-	  XMLSchema.
-
-	  http://pyxb.sourceforge.net/
diff --git a/package/python-pyxb/python-pyxb.hash b/package/python-pyxb/python-pyxb.hash
deleted file mode 100644
index f24cd42e5a..0000000000
--- a/package/python-pyxb/python-pyxb.hash
+++ /dev/null
@@ -1,4 +0,0 @@ 
-# md5 from https://pypi.python.org/pypi/PyXB/json, sha256 locally computed
-md5  4303573fc7094ce4664c5b71cd4bdb48  PyXB-1.2.6.tar.gz
-sha256  2a00f38dd1d87b88f92d79bc5a09718d730419b88e814545f472bbd5a3bf27b4  PyXB-1.2.6.tar.gz
-sha256  cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30  LICENSE
diff --git a/package/python-pyxb/python-pyxb.mk b/package/python-pyxb/python-pyxb.mk
deleted file mode 100644
index 6af10b51e7..0000000000
--- a/package/python-pyxb/python-pyxb.mk
+++ /dev/null
@@ -1,14 +0,0 @@ 
-################################################################################
-#
-# python-pyxb
-#
-################################################################################
-
-PYTHON_PYXB_VERSION = 1.2.6
-PYTHON_PYXB_SOURCE = PyXB-$(PYTHON_PYXB_VERSION).tar.gz
-PYTHON_PYXB_SITE = https://pypi.python.org/packages/e3/09/4fdb190ea2b7cb43d6d3e745276ee69f4d6181be70fcbfda7df3c5f72f0e
-PYTHON_PYXB_LICENSE = Apache-2.0
-PYTHON_PYXB_LICENSE_FILES = LICENSE
-PYTHON_PYXB_SETUP_TYPE = distutils
-
-$(eval $(python-package))