diff mbox series

[1/1] package/yaml-cpp: fix library name

Message ID 20230716163707.420531-1-bernd@kuhls.net
State Accepted
Headers show
Series [1/1] package/yaml-cpp: fix library name | expand

Commit Message

Bernd Kuhls July 16, 2023, 4:37 p.m. UTC
In the current state this package install libyaml-cppd.so due to "d"
being added because the variable CMAKE_DEBUG_POSTFIX is not set:
https://github.com/jbeder/yaml-cpp/blob/master/CMakeLists.txt#L137

This breaks the build of mongodb which expects the library name
libyaml-cpp.so:
https://github.com/mongodb/mongo/blob/master/SConstruct#L5090

Fixes:
http://autobuild.buildroot.net/results/304/3044d040dec090a2f528a96f201d4e554f6779b4/

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
 package/yaml-cpp/yaml-cpp.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni July 21, 2023, 9:31 p.m. UTC | #1
On Sun, 16 Jul 2023 18:37:07 +0200
Bernd Kuhls <bernd@kuhls.net> wrote:

> In the current state this package install libyaml-cppd.so due to "d"
> being added because the variable CMAKE_DEBUG_POSTFIX is not set:
> https://github.com/jbeder/yaml-cpp/blob/master/CMakeLists.txt#L137
> 
> This breaks the build of mongodb which expects the library name
> libyaml-cpp.so:
> https://github.com/mongodb/mongo/blob/master/SConstruct#L5090
> 
> Fixes:
> http://autobuild.buildroot.net/results/304/3044d040dec090a2f528a96f201d4e554f6779b4/
> 
> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
> ---
>  package/yaml-cpp/yaml-cpp.mk | 1 +
>  1 file changed, 1 insertion(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 29, 2023, 4:46 p.m. UTC | #2
>>>>> "Bernd" == Bernd Kuhls <bernd@kuhls.net> writes:

 > In the current state this package install libyaml-cppd.so due to "d"
 > being added because the variable CMAKE_DEBUG_POSTFIX is not set:
 > https://github.com/jbeder/yaml-cpp/blob/master/CMakeLists.txt#L137

 > This breaks the build of mongodb which expects the library name
 > libyaml-cpp.so:
 > https://github.com/mongodb/mongo/blob/master/SConstruct#L5090

 > Fixes:
 > http://autobuild.buildroot.net/results/304/3044d040dec090a2f528a96f201d4e554f6779b4/

 > Signed-off-by: Bernd Kuhls <bernd@kuhls.net>

Committed to 2023.02.x and 2023.05.x, thanks.
diff mbox series

Patch

diff --git a/package/yaml-cpp/yaml-cpp.mk b/package/yaml-cpp/yaml-cpp.mk
index d65298ffb9..367df27ff1 100644
--- a/package/yaml-cpp/yaml-cpp.mk
+++ b/package/yaml-cpp/yaml-cpp.mk
@@ -13,6 +13,7 @@  YAML_CPP_CPE_ID_VENDOR = yaml-cpp_project
 
 # Disable testing and parse tools
 YAML_CPP_CONF_OPTS += \
+	-DCMAKE_DEBUG_POSTFIX="" \
 	-DYAML_CPP_BUILD_TESTS=OFF \
 	-DYAML_CPP_BUILD_TOOLS=OFF