diff mbox series

[3/7] package/gd: add optional support for libheif

Message ID 20230708200447.3919009-3-bernd@kuhls.net
State Accepted
Headers show
Series [1/7] package/libde265: new package | expand

Commit Message

Bernd Kuhls July 8, 2023, 8:04 p.m. UTC
Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
 package/gd/gd.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni July 30, 2023, 10:27 a.m. UTC | #1
On Sat,  8 Jul 2023 22:04:43 +0200
Bernd Kuhls <bernd@kuhls.net> wrote:

> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
> ---
>  package/gd/gd.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/gd/gd.mk b/package/gd/gd.mk
index 55c12e6968..969c02aade 100644
--- a/package/gd/gd.mk
+++ b/package/gd/gd.mk
@@ -44,6 +44,13 @@  GD_DEPENDENCIES += jpeg
 GD_CONF_OPTS += --with-jpeg
 endif
 
+ifeq ($(BR2_PACKAGE_LIBHEIF),y)
+GD_DEPENDENCIES += libheif
+GD_CONF_OPTS += --with-heif
+else
+GD_CONF_OPTS += --without-heif
+endif
+
 ifeq ($(BR2_PACKAGE_LIBPNG),y)
 GD_DEPENDENCIES += libpng
 GD_CONF_OPTS += --with-png