diff mbox series

package/pounce: New package

Message ID 20230708193520.31844-1-ismael@iodev.co.uk
State Not Applicable
Headers show
Series package/pounce: New package | expand

Commit Message

Ismael Luceno July 8, 2023, 7:35 p.m. UTC
Simple IRC bouncer.

Signed-off-by: Ismael Luceno <ismael@iodev.co.uk>
---
 DEVELOPERS                 |  1 +
 package/Config.in          |  1 +
 package/pounce/Config.in   | 18 ++++++++++++++++++
 package/pounce/pounce.hash |  3 +++
 package/pounce/pounce.mk   | 14 ++++++++++++++
 5 files changed, 37 insertions(+)
 create mode 100644 package/pounce/Config.in
 create mode 100644 package/pounce/pounce.hash
 create mode 100644 package/pounce/pounce.mk
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 188c579010a5..cbcd7a7527ea 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1322,6 +1322,7 @@  F:	package/exempi/
 N:	Ismael Luceno <ismael@iodev.co.uk>
 F:	package/axel/
 F:	package/mawk/
+F:	package/pounce/
 
 N:	Jagan Teki <jagan@amarulasolutions.com>
 F:	board/amarula/
diff --git a/package/Config.in b/package/Config.in
index bff090a66163..b2bda179a402 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -2444,6 +2444,7 @@  endif
 	source "package/phytool/Config.in"
 	source "package/pimd/Config.in"
 	source "package/pixiewps/Config.in"
+	source "package/pounce/Config.in"
 	source "package/pound/Config.in"
 	source "package/pppd/Config.in"
 	source "package/pptp-linux/Config.in"
diff --git a/package/pounce/Config.in b/package/pounce/Config.in
new file mode 100644
index 000000000000..83bb66643652
--- /dev/null
+++ b/package/pounce/Config.in
@@ -0,0 +1,18 @@ 
+config BR2_PACKAGE_POUNCE
+	bool "pounce"
+	select BR2_PACKAGE_LIBRESSL
+	help
+	  pounce is a multi-client, TLS-only IRC bouncer. It maintains a
+	  persistent connection to an IRC server, acting as a proxy and
+	  buffer for a number of clients. When a client connects, any
+	  messages received since it last disconnected will be relayed to
+	  it. Unlike some other bouncers, pounce uses a single buffer for
+	  all IRC messages, which acts as a queue from which each client
+	  reads messages independently.
+
+	  pounce speaks regular modern IRC to both servers and clients, using
+	  the server-time extension to indicate when messages originally
+	  occurred. Clients identify themselves to pounce by their IRC
+	  usernames.
+
+	  https://git.causal.agency/pounce/
diff --git a/package/pounce/pounce.hash b/package/pounce/pounce.hash
new file mode 100644
index 000000000000..a827bd389f40
--- /dev/null
+++ b/package/pounce/pounce.hash
@@ -0,0 +1,3 @@ 
+# Locally computed
+sha256  97f245556b1cc940553fca18f4d7d82692e6c11a30f612415e5e391e5d96604e  pounce-3.1.tar.gz
+sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  LICENSE
diff --git a/package/pounce/pounce.mk b/package/pounce/pounce.mk
new file mode 100644
index 000000000000..b9a0bf06a8d9
--- /dev/null
+++ b/package/pounce/pounce.mk
@@ -0,0 +1,14 @@ 
+################################################################################
+#
+# pounce
+#
+################################################################################
+
+POUNCE_VERSION = 3.1
+POUNCE_SITE = https://git.causal.agency/pounce/
+POUNCE_SOURCE = pounce-$(POUNCE_VERSION).tar.gz
+POUNCE_LICENSE = GPL-3.0+
+POUNCE_LICENSE_FILES = LICENSE
+POUNCE_DEPENDENCIES = libressl
+
+$(eval $(autotools-package))