diff mbox series

[2/2] package/mrouted: add /var/lib/misc for systemd builds

Message ID 20230604154818.3681851-3-troglobit@gmail.com
State Accepted
Headers show
Series mrouted upgrade with systemd build fix | expand

Commit Message

Joachim Wiberg June 4, 2023, 3:48 p.m. UTC
Similar to dnsmasq, mrouted saves state data across reboots in the
/var/lib/misc/ directory.  In the case of mrouted it is the unique
generation id (used by neighboring mrouted routers to identify any
router restarting).  This file is generated on first boot.

Workaround only needed for systemd builds, the sysv skeleton already
has the /var/lib/misc/ directory.

Signed-off-by: Joachim Wiberg <troglobit@gmail.com>
---
 package/mrouted/mrouted.mk | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/package/mrouted/mrouted.mk b/package/mrouted/mrouted.mk
index 3e2f49dc10..0d2071c4f0 100644
--- a/package/mrouted/mrouted.mk
+++ b/package/mrouted/mrouted.mk
@@ -18,6 +18,7 @@  define MROUTED_INSTALL_INIT_SYSV
 endef
 
 define MROUTED_INSTALL_INIT_SYSTEMD
+	mkdir -p $(TARGET_DIR)/var/lib/misc/
 	$(INSTALL) -D -m 644 $(@D)/mrouted.service \
 		$(TARGET_DIR)/usr/lib/systemd/system/mrouted.service
 endef