diff mbox series

[1/1] package/pulseaudio: fix build without avahi-client

Message ID 20230308174402.7574-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/pulseaudio: fix build without avahi-client | expand

Commit Message

Fabrice Fontaine March 8, 2023, 5:44 p.m. UTC
Fix the following build failure without avahi-client raised since commit
7752afbe4bb9fa1def5ba89daf21564ea58af79a (before this commit, avahi was
silently disabled):

../output-1/build/pulseaudio-16.1/meson.build:754:2: ERROR: Dependency "avahi-client" not found, tried pkgconfig and cmake

Fixes:
 - http://autobuild.buildroot.org/results/0aea014eb4ed27870af908668d7b138d150f065a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/pulseaudio/pulseaudio.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard March 8, 2023, 8:26 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure without avahi-client raised since commit
 > 7752afbe4bb9fa1def5ba89daf21564ea58af79a (before this commit, avahi was
 > silently disabled):

 > ../output-1/build/pulseaudio-16.1/meson.build:754:2: ERROR: Dependency
 > "avahi-client" not found, tried pkgconfig and cmake

 > Fixes:
 >  - http://autobuild.buildroot.org/results/0aea014eb4ed27870af908668d7b138d150f065a

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard March 15, 2023, 3:03 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure without avahi-client raised since commit
 > 7752afbe4bb9fa1def5ba89daf21564ea58af79a (before this commit, avahi was
 > silently disabled):

 > ../output-1/build/pulseaudio-16.1/meson.build:754:2: ERROR: Dependency
 > "avahi-client" not found, tried pkgconfig and cmake

 > Fixes:
 >  - http://autobuild.buildroot.org/results/0aea014eb4ed27870af908668d7b138d150f065a

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.11.x, thanks.
diff mbox series

Patch

diff --git a/package/pulseaudio/pulseaudio.mk b/package/pulseaudio/pulseaudio.mk
index 8c4b99b6ff..89191db541 100644
--- a/package/pulseaudio/pulseaudio.mk
+++ b/package/pulseaudio/pulseaudio.mk
@@ -25,7 +25,7 @@  PULSEAUDIO_DEPENDENCIES = \
 
 PULSEAUDIO_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
 
-ifeq ($(BR2_PACKAGE_AVAHI_DAEMON),y)
+ifeq ($(BR2_PACKAGE_AVAHI_LIBAVAHI_CLIENT),y)
 PULSEAUDIO_CONF_OPTS += -Davahi=enabled
 PULSEAUDIO_DEPENDENCIES += avahi
 else