diff mbox series

[v6,04/13] package/qt6/qt6base: add support for widgets

Message ID 20230207171721.2973997-5-angelo@amarulasolutions.com
State Accepted
Headers show
Series Extend Qt6 configuration | expand

Commit Message

Angelo Compagnucci Feb. 7, 2023, 5:17 p.m. UTC
Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
---
v6:
* Removed backend configuration options (Thomas P.)

 package/qt6/qt6base/Config.in  | 6 ++++++
 package/qt6/qt6base/qt6base.mk | 4 ++++
 2 files changed, 10 insertions(+)

Comments

Thomas Petazzoni Feb. 8, 2023, 11:09 a.m. UTC | #1
On Tue,  7 Feb 2023 18:17:12 +0100
Angelo Compagnucci <angelo@amarulasolutions.com> wrote:

> +config BR2_PACKAGE_QT6BASE_WIDGETS
> +	bool "widgets module"
> +	select BR2_PACKAGE_XLIB_LIBXEXT if BR2_PACKAGE_QT6BASE_XCB

According to my build testing, this dependency is not needed, so I
dropped it.

> +	help
> +	  This option enables the Qt6Widgets library.
> +
>  endif
>  
>  config BR2_PACKAGE_QT6BASE_NETWORK
> diff --git a/package/qt6/qt6base/qt6base.mk b/package/qt6/qt6base/qt6base.mk
> index 06ebbab8e7..cf3c7b1ad1 100644
> --- a/package/qt6/qt6base/qt6base.mk
> +++ b/package/qt6/qt6base/qt6base.mk
> @@ -213,6 +213,10 @@ else
>  QT6BASE_CONF_OPTS += -DFEATURE_fontconfig=OFF
>  endif
>  
> +ifeq ($(BR2_PACKAGE_QT6BASE_WIDGETS),y)
> +QT6BASE_CONF_OPTS += -DFEATURE_widgets=ON

Missing else clause to explicitly disable widgets.

Applied with these two things fixed. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/qt6/qt6base/Config.in b/package/qt6/qt6base/Config.in
index 6c5c60fa30..0f7e936162 100644
--- a/package/qt6/qt6base/Config.in
+++ b/package/qt6/qt6base/Config.in
@@ -95,6 +95,12 @@  config BR2_PACKAGE_QT6BASE_PNG
 	  This option enables PNG support using the system libpng
 	  library.
 
+config BR2_PACKAGE_QT6BASE_WIDGETS
+	bool "widgets module"
+	select BR2_PACKAGE_XLIB_LIBXEXT if BR2_PACKAGE_QT6BASE_XCB
+	help
+	  This option enables the Qt6Widgets library.
+
 endif
 
 config BR2_PACKAGE_QT6BASE_NETWORK
diff --git a/package/qt6/qt6base/qt6base.mk b/package/qt6/qt6base/qt6base.mk
index 06ebbab8e7..cf3c7b1ad1 100644
--- a/package/qt6/qt6base/qt6base.mk
+++ b/package/qt6/qt6base/qt6base.mk
@@ -213,6 +213,10 @@  else
 QT6BASE_CONF_OPTS += -DFEATURE_fontconfig=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_QT6BASE_WIDGETS),y)
+QT6BASE_CONF_OPTS += -DFEATURE_widgets=ON
+endif
+
 else
 QT6BASE_CONF_OPTS += -DFEATURE_gui=OFF
 endif