diff mbox series

[v6,11/13] package/qt6/qt6base: add support for printsupport/cups

Message ID 20230207171721.2973997-12-angelo@amarulasolutions.com
State Accepted
Headers show
Series Extend Qt6 configuration | expand

Commit Message

Angelo Compagnucci Feb. 7, 2023, 5:17 p.m. UTC
From: Jesse Van Gavere <jesseevg@gmail.com>

Signed-off-by: Jesse Van Gavere <jesseevg@gmail.com>
Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
---
 package/qt6/qt6base/Config.in  |  4 ++++
 package/qt6/qt6base/qt6base.mk | 12 ++++++++++++
 2 files changed, 16 insertions(+)

Comments

Thomas Petazzoni Feb. 8, 2023, 11:15 a.m. UTC | #1
On Tue,  7 Feb 2023 18:17:19 +0100
Angelo Compagnucci <angelo@amarulasolutions.com> wrote:

> From: Jesse Van Gavere <jesseevg@gmail.com>
> 
> Signed-off-by: Jesse Van Gavere <jesseevg@gmail.com>
> Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
> ---
>  package/qt6/qt6base/Config.in  |  4 ++++
>  package/qt6/qt6base/qt6base.mk | 12 ++++++++++++
>  2 files changed, 16 insertions(+)
> 
> diff --git a/package/qt6/qt6base/Config.in b/package/qt6/qt6base/Config.in
> index d5d6d3569d..4d13128661 100644
> --- a/package/qt6/qt6base/Config.in
> +++ b/package/qt6/qt6base/Config.in
> @@ -168,6 +168,10 @@ config BR2_PACKAGE_QT6BASE_NETWORK
>  	help
>  	  This options enables the Qt6Network library.
>  
> +config BR2_PACKAGE_QT6BASE_PRINTSUPPORT
> +	depends on BR2_PACKAGE_QT6BASE_WIDGETS
> +	def_bool y

Why is that a def_bool y? I see it's like that in qt5base, but I'm not
sure why. I changed it to be a normal option:

config BR2_PACKAGE_QT6BASE_PRINTSUPPORT
        bool "printing support"
        # yes, print support needs widgets
        depends on BR2_PACKAGE_QT6BASE_WIDGETS
        help
          This option enables printing support, optionally using CUPS
          if available.

> diff --git a/package/qt6/qt6base/qt6base.mk b/package/qt6/qt6base/qt6base.mk
> index 4a64886a3f..97986a3c2b 100644
> --- a/package/qt6/qt6base/qt6base.mk
> +++ b/package/qt6/qt6base/qt6base.mk
> @@ -206,6 +206,18 @@ else
>  QT6BASE_CONF_OPTS += -DFEATURE_jpeg=OFF
>  endif
>  
> +ifeq ($(BR2_PACKAGE_QT6BASE_PRINTSUPPORT), y)

Spurious space before y

> +QT6BASE_CONF_OPTS += -DFEATURE_printsupport=ON
> +ifeq ($(BR2_PACKAGE_CUPS), y)

Same.

Applied with those fixes. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/qt6/qt6base/Config.in b/package/qt6/qt6base/Config.in
index d5d6d3569d..4d13128661 100644
--- a/package/qt6/qt6base/Config.in
+++ b/package/qt6/qt6base/Config.in
@@ -168,6 +168,10 @@  config BR2_PACKAGE_QT6BASE_NETWORK
 	help
 	  This options enables the Qt6Network library.
 
+config BR2_PACKAGE_QT6BASE_PRINTSUPPORT
+	depends on BR2_PACKAGE_QT6BASE_WIDGETS
+	def_bool y
+
 config BR2_PACKAGE_QT6BASE_SQL
 	bool "sql module"
 	help
diff --git a/package/qt6/qt6base/qt6base.mk b/package/qt6/qt6base/qt6base.mk
index 4a64886a3f..97986a3c2b 100644
--- a/package/qt6/qt6base/qt6base.mk
+++ b/package/qt6/qt6base/qt6base.mk
@@ -206,6 +206,18 @@  else
 QT6BASE_CONF_OPTS += -DFEATURE_jpeg=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_QT6BASE_PRINTSUPPORT), y)
+QT6BASE_CONF_OPTS += -DFEATURE_printsupport=ON
+ifeq ($(BR2_PACKAGE_CUPS), y)
+QT6BASE_CONF_OPTS += -DFEATURE_cups=ON
+QT6BASE_DEPENDENCIES += cups
+else
+QT6BASE_CONF_OPTS += -DFEATURE_cups=OFF
+endif
+else
+QT6BASE_CONF_OPTS += -DFEATURE_printsupport=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_LIBDRM),y)
 QT6BASE_CONF_OPTS += -DFEATURE_kms=ON
 QT6BASE_DEPENDENCIES += libdrm