diff mbox series

[1/1] package/tmux: add utf8proc optional dependency

Message ID 20230205132307.41753-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/tmux: add utf8proc optional dependency | expand

Commit Message

Fabrice Fontaine Feb. 5, 2023, 1:23 p.m. UTC
utf8proc is an optional dependency since version 2.3 and
https://github.com/tmux/tmux/commit/6c94774b70f72952c4c512e4aa59a207ca1c34f2

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/tmux/tmux.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Yann E. MORIN Feb. 5, 2023, 2:42 p.m. UTC | #1
Fabrice, All,

On 2023-02-05 14:23 +0100, Fabrice Fontaine spake thusly:
> utf8proc is an optional dependency since version 2.3 and
> https://github.com/tmux/tmux/commit/6c94774b70f72952c4c512e4aa59a207ca1c34f2
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/tmux/tmux.mk | 7 +++++++
>  1 file changed, 7 insertions(+)
> 
> diff --git a/package/tmux/tmux.mk b/package/tmux/tmux.mk
> index 281b7d8ee6..b1c0af1a83 100644
> --- a/package/tmux/tmux.mk
> +++ b/package/tmux/tmux.mk
> @@ -11,6 +11,13 @@ TMUX_LICENSE_FILES = COPYING
>  TMUX_CPE_ID_VENDOR = tmux_project
>  TMUX_DEPENDENCIES = libevent ncurses host-pkgconf
>  
> +ifeq ($(BR2_PACKAGE_UTF8PROC),y)
> +TMUX_DEPENDENCIES += utf8proc
> +TMUX_CONF_OPTS += --enable-utf8proc
> +else
> +TMUX_CONF_OPTS += --disable-utf8proc
> +endif
> +
>  # Add /usr/bin/tmux to /etc/shells otherwise some login tools like dropbear
>  # can reject the user connection. See man shells.
>  define TMUX_ADD_TMUX_TO_SHELLS
> -- 
> 2.39.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Feb. 21, 2023, 8:46 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > utf8proc is an optional dependency since version 2.3 and
 > https://github.com/tmux/tmux/commit/6c94774b70f72952c4c512e4aa59a207ca1c34f2

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.11.x and 2022.02.x, thanks.

> ---
 >  package/tmux/tmux.mk | 7 +++++++
 >  1 file changed, 7 insertions(+)

 > diff --git a/package/tmux/tmux.mk b/package/tmux/tmux.mk
 > index 281b7d8ee6..b1c0af1a83 100644
 > --- a/package/tmux/tmux.mk
 > +++ b/package/tmux/tmux.mk
 > @@ -11,6 +11,13 @@ TMUX_LICENSE_FILES = COPYING
 >  TMUX_CPE_ID_VENDOR = tmux_project
 >  TMUX_DEPENDENCIES = libevent ncurses host-pkgconf
 
 > +ifeq ($(BR2_PACKAGE_UTF8PROC),y)
 > +TMUX_DEPENDENCIES += utf8proc
 > +TMUX_CONF_OPTS += --enable-utf8proc
 > +else
 > +TMUX_CONF_OPTS += --disable-utf8proc
 > +endif
 > +
 >  # Add /usr/bin/tmux to /etc/shells otherwise some login tools like dropbear
 >  # can reject the user connection. See man shells.
 >  define TMUX_ADD_TMUX_TO_SHELLS
 > -- 

 > 2.39.0

 > _______________________________________________
 > buildroot mailing list
 > buildroot@buildroot.org
 > https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/tmux/tmux.mk b/package/tmux/tmux.mk
index 281b7d8ee6..b1c0af1a83 100644
--- a/package/tmux/tmux.mk
+++ b/package/tmux/tmux.mk
@@ -11,6 +11,13 @@  TMUX_LICENSE_FILES = COPYING
 TMUX_CPE_ID_VENDOR = tmux_project
 TMUX_DEPENDENCIES = libevent ncurses host-pkgconf
 
+ifeq ($(BR2_PACKAGE_UTF8PROC),y)
+TMUX_DEPENDENCIES += utf8proc
+TMUX_CONF_OPTS += --enable-utf8proc
+else
+TMUX_CONF_OPTS += --disable-utf8proc
+endif
+
 # Add /usr/bin/tmux to /etc/shells otherwise some login tools like dropbear
 # can reject the user connection. See man shells.
 define TMUX_ADD_TMUX_TO_SHELLS