diff mbox series

[1/1] package/xtables-addons: bump to version 3.22

Message ID 20221222222840.51146-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/xtables-addons: bump to version 3.22 | expand

Commit Message

Fabrice Fontaine Dec. 22, 2022, 10:28 p.m. UTC
Support for up to Linux 6.1 by fixing the following build failure:

/tmp/instance-5/output-1/build/xtables-addons-3.21/extensions/xt_CHAOS.c: In function ‘xt_chaos_total’:
/tmp/instance-5/output-1/build/xtables-addons-3.21/extensions/xt_CHAOS.c:70:46: error: implicit declaration of function ‘prandom_u32’; did you mean ‘prandom_u32_max’? [-Werror=implicit-function-declaration]
   70 |         if (!ret || hotdrop || (unsigned int)prandom_u32() > delude_percentage)
      |                                              ^~~~~~~~~~~
      |                                              prandom_u32_max

https://fossies.org/linux/privat/xtables-addons-3.22.tar.xz/xtables-addons-3.22/doc/changelog.rst

Fixes:
 - http://autobuild.buildroot.org/results/4564ba888156710819f6bd86117e0c0bdd513dba

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/xtables-addons/xtables-addons.hash | 2 +-
 package/xtables-addons/xtables-addons.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Dec. 23, 2022, 9:34 a.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Support for up to Linux 6.1 by fixing the following build failure:
 > /tmp/instance-5/output-1/build/xtables-addons-3.21/extensions/xt_CHAOS.c: In function ‘xt_chaos_total’:
 > /tmp/instance-5/output-1/build/xtables-addons-3.21/extensions/xt_CHAOS.c:70:46:
 > error: implicit declaration of function ‘prandom_u32’; did you mean
 > ‘prandom_u32_max’? [-Werror=implicit-function-declaration]
 >    70 |         if (!ret || hotdrop || (unsigned int)prandom_u32() > delude_percentage)
 >       |                                              ^~~~~~~~~~~
 >       |                                              prandom_u32_max

 > https://fossies.org/linux/privat/xtables-addons-3.22.tar.xz/xtables-addons-3.22/doc/changelog.rst

 > Fixes:
 >  - http://autobuild.buildroot.org/results/4564ba888156710819f6bd86117e0c0bdd513dba

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/xtables-addons/xtables-addons.hash b/package/xtables-addons/xtables-addons.hash
index 0d2434eeb1..840a31f947 100644
--- a/package/xtables-addons/xtables-addons.hash
+++ b/package/xtables-addons/xtables-addons.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  2e09ac129a14f5e9c23b115ebcdfff4aa84e2aeba1268dbdf39b2d752bd71e19  xtables-addons-3.21.tar.xz
+sha256  faa16a27166275afbfe8df605f55c3a81ac693bf19da674d45ceded4137ae217  xtables-addons-3.22.tar.xz
 sha256  ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6  LICENSE
diff --git a/package/xtables-addons/xtables-addons.mk b/package/xtables-addons/xtables-addons.mk
index 83cc3266c4..77dcfd741c 100644
--- a/package/xtables-addons/xtables-addons.mk
+++ b/package/xtables-addons/xtables-addons.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-XTABLES_ADDONS_VERSION = 3.21
+XTABLES_ADDONS_VERSION = 3.22
 XTABLES_ADDONS_SOURCE = xtables-addons-$(XTABLES_ADDONS_VERSION).tar.xz
 XTABLES_ADDONS_SITE = https://inai.de/files/xtables-addons
 XTABLES_ADDONS_DEPENDENCIES = iptables linux host-pkgconf