diff mbox series

[1/1] package/domoticz: bump to version 2022.2

Message ID 20221218113856.217724-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/domoticz: bump to version 2022.2 | expand

Commit Message

Fabrice Fontaine Dec. 18, 2022, 11:38 a.m. UTC
https://github.com/domoticz/domoticz/blob/2022.2/History.txt

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 ...e-EnOceanRawValue.h-include-stdarg.h.patch | 33 +++++++++++++++++++
 package/domoticz/domoticz.hash                |  2 +-
 package/domoticz/domoticz.mk                  |  2 +-
 3 files changed, 35 insertions(+), 2 deletions(-)
 create mode 100644 package/domoticz/0001-hardware-EnOceanRawValue.h-include-stdarg.h.patch

Comments

Peter Korsgaard Dec. 18, 2022, 1:58 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > https://github.com/domoticz/domoticz/blob/2022.2/History.txt
 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/domoticz/0001-hardware-EnOceanRawValue.h-include-stdarg.h.patch b/package/domoticz/0001-hardware-EnOceanRawValue.h-include-stdarg.h.patch
new file mode 100644
index 0000000000..bc3e60023d
--- /dev/null
+++ b/package/domoticz/0001-hardware-EnOceanRawValue.h-include-stdarg.h.patch
@@ -0,0 +1,33 @@ 
+From 6296d7112089a0f3bfb3056f6d9637e13ce4ce83 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Sun, 18 Dec 2022 12:27:38 +0100
+Subject: [PATCH] hardware/EnOceanRawValue.h: include stdarg.h
+
+Include stdarg.h to avoid the following build failure on uclibc:
+
+In file included from /home/fabrice/buildroot/output/build/domoticz-2022.2/hardware/EnOceanRawValue.cpp:2:
+/home/fabrice/buildroot/output/build/domoticz-2022.2/hardware/EnOceanRawValue.h:109:83: error: 'va_list' has not been declared
+  109 | uint32_t SetRawValuesNb(uint8_t * data, T_DATAFIELD * OffsetDes, int NbParameter, va_list value);
+      |                                                                                   ^~~~~~~
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status: https://github.com/domoticz/domoticz/pull/5472]
+---
+ hardware/EnOceanRawValue.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/hardware/EnOceanRawValue.h b/hardware/EnOceanRawValue.h
+index 84f38d17a..df858f27d 100644
+--- a/hardware/EnOceanRawValue.h
++++ b/hardware/EnOceanRawValue.h
+@@ -1,6 +1,7 @@
+ #ifndef _SetGetRawValue
+ #define _SetGetRawValue
+ 
++#include <stdarg.h>
+ #include <stdint.h>
+ #include <vector>
+ #include <stdio.h>
+-- 
+2.35.1
+
diff --git a/package/domoticz/domoticz.hash b/package/domoticz/domoticz.hash
index 9de241015c..c439238800 100644
--- a/package/domoticz/domoticz.hash
+++ b/package/domoticz/domoticz.hash
@@ -1,3 +1,3 @@ 
 # Locally computed:
-sha256  8282cb71c924b6ef92503976d50f966f2c785eab8f8cffa1136ac133f0241157  domoticz-2022.1.tar.gz
+sha256  8f84098bb64bec12ff7aac5f1fb6b6230a88c5781c2b75bc89861caea73cbccf  domoticz-2022.2.tar.gz
 sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  License.txt
diff --git a/package/domoticz/domoticz.mk b/package/domoticz/domoticz.mk
index bc4a2def41..451021150b 100644
--- a/package/domoticz/domoticz.mk
+++ b/package/domoticz/domoticz.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-DOMOTICZ_VERSION = 2022.1
+DOMOTICZ_VERSION = 2022.2
 DOMOTICZ_SITE = $(call github,domoticz,domoticz,$(DOMOTICZ_VERSION))
 DOMOTICZ_LICENSE = GPL-3.0
 DOMOTICZ_LICENSE_FILES = License.txt