diff mbox series

[1/1] package/usbguard: fix build without asciidoc

Message ID 20221026201736.327835-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/usbguard: fix build without asciidoc | expand

Commit Message

Fabrice Fontaine Oct. 26, 2022, 8:17 p.m. UTC
Set ac_cv_prog_A2X to disable build of documentation and avoid the
following build failure without a working a2x raised since at least bump
to version 1.1.1 in commit ad21d84a589458fd4542993912891daa503d72dd:

a2x -v -f manpage doc/man/usbguard.1.adoc -D ./$(dirname doc/man/usbguard.1.roff)
a2x -v -f manpage doc/man/usbguard-dbus.8.adoc -D ./$(dirname doc/man/usbguard-dbus.8.roff)
/nvmedata/autobuild/instance-5/output-1/host/bin/python3: Error while finding module specification for 'asciidoc.a2x' (ModuleNotFoundError: No module named 'asciidoc')

Fixes:
 - http://autobuild.buildroot.org/results/e41950f3cd4bd83d9b067af498757cb9d2f207ef

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/usbguard/usbguard.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Oct. 27, 2022, 6:49 a.m. UTC | #1
On Wed, 26 Oct 2022 22:17:36 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Set ac_cv_prog_A2X to disable build of documentation and avoid the
> following build failure without a working a2x raised since at least bump
> to version 1.1.1 in commit ad21d84a589458fd4542993912891daa503d72dd:
> 
> a2x -v -f manpage doc/man/usbguard.1.adoc -D ./$(dirname doc/man/usbguard.1.roff)
> a2x -v -f manpage doc/man/usbguard-dbus.8.adoc -D ./$(dirname doc/man/usbguard-dbus.8.roff)
> /nvmedata/autobuild/instance-5/output-1/host/bin/python3: Error while finding module specification for 'asciidoc.a2x' (ModuleNotFoundError: No module named 'asciidoc')
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/e41950f3cd4bd83d9b067af498757cb9d2f207ef
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/usbguard/usbguard.mk | 1 +
>  1 file changed, 1 insertion(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Nov. 8, 2022, 7:36 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Set ac_cv_prog_A2X to disable build of documentation and avoid the
 > following build failure without a working a2x raised since at least bump
 > to version 1.1.1 in commit ad21d84a589458fd4542993912891daa503d72dd:

 > a2x -v -f manpage doc/man/usbguard.1.adoc -D ./$(dirname doc/man/usbguard.1.roff)
 > a2x -v -f manpage doc/man/usbguard-dbus.8.adoc -D ./$(dirname doc/man/usbguard-dbus.8.roff)
 > /nvmedata/autobuild/instance-5/output-1/host/bin/python3: Error while
 > finding module specification for 'asciidoc.a2x' (ModuleNotFoundError:
 > No module named 'asciidoc')

 > Fixes:
 >  - http://autobuild.buildroot.org/results/e41950f3cd4bd83d9b067af498757cb9d2f207ef

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.08.x, thanks.
diff mbox series

Patch

diff --git a/package/usbguard/usbguard.mk b/package/usbguard/usbguard.mk
index ca539a55f5..4e906e8b87 100644
--- a/package/usbguard/usbguard.mk
+++ b/package/usbguard/usbguard.mk
@@ -10,6 +10,7 @@  USBGUARD_LICENSE = GPL-2.0+
 USBGUARD_LICENSE_FILES = LICENSE
 USBGUARD_CPE_ID_VENDOR = usbguard_project
 USBGUARD_SELINUX_MODULES = usbguard
+USBGUARD_CONF_ENV = ac_cv_prog_A2X=""
 USBGUARD_CONF_OPTS = \
 	--with-bundled-catch \
 	--with-bundled-pegtl \