diff mbox series

[1/1] package/go: security bump to 1.19.2

Message ID 20221026193508.482276-1-christian@paral.in
State Accepted
Headers show
Series [1/1] package/go: security bump to 1.19.2 | expand

Commit Message

Christian Stewart Oct. 26, 2022, 7:35 p.m. UTC
go1.19.2 includes security fixes to the archive/tar, net/http/httputil, and
regexp packages, as well as bug fixes to the compiler, the linker, the runtime,
and the go/types package.

https://go.dev/doc/devel/release#go1.19
https://github.com/golang/go/issues?q=milestone%3AGo1.19.2+label%3ACherryPickApproved

Signed-off-by: Christian Stewart <christian@paral.in>
---
 package/go/go.hash | 2 +-
 package/go/go.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Oct. 26, 2022, 7:50 p.m. UTC | #1
On Wed, 26 Oct 2022 12:35:08 -0700
Christian Stewart via buildroot <buildroot@buildroot.org> wrote:

> go1.19.2 includes security fixes to the archive/tar, net/http/httputil, and
> regexp packages, as well as bug fixes to the compiler, the linker, the runtime,
> and the go/types package.
> 
> https://go.dev/doc/devel/release#go1.19
> https://github.com/golang/go/issues?q=milestone%3AGo1.19.2+label%3ACherryPickApproved
> 
> Signed-off-by: Christian Stewart <christian@paral.in>
> ---
>  package/go/go.hash | 2 +-
>  package/go/go.mk   | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Nov. 5, 2022, 9:42 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni via buildroot <buildroot@buildroot.org> writes:

 > On Wed, 26 Oct 2022 12:35:08 -0700
 > Christian Stewart via buildroot <buildroot@buildroot.org> wrote:

 >> go1.19.2 includes security fixes to the archive/tar, net/http/httputil, and
 >> regexp packages, as well as bug fixes to the compiler, the linker, the runtime,
 >> and the go/types package.
 >> 
 >> https://go.dev/doc/devel/release#go1.19
 >> https://github.com/golang/go/issues?q=milestone%3AGo1.19.2+label%3ACherryPickApproved
 >> 
 >> Signed-off-by: Christian Stewart <christian@paral.in>
 >> ---
 >> package/go/go.hash | 2 +-
 >> package/go/go.mk   | 2 +-
 >> 2 files changed, 2 insertions(+), 2 deletions(-)

 > Applied to master, thanks.

I have instead updated 2022.02.x and 2022.08.x to 1.18.8, which includes
the same security fixes.
diff mbox series

Patch

diff --git a/package/go/go.hash b/package/go/go.hash
index 657475adef..f944bd5304 100644
--- a/package/go/go.hash
+++ b/package/go/go.hash
@@ -1,3 +1,3 @@ 
 # From https://go.dev/dl
-sha256  27871baa490f3401414ad793fba49086f6c855b1c584385ed7771e1204c7e179  go1.19.1.src.tar.gz
+sha256  2ce930d70a931de660fdaf271d70192793b1b240272645bf0275779f6704df6b  go1.19.2.src.tar.gz
 sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
diff --git a/package/go/go.mk b/package/go/go.mk
index 9f0fbbde00..fe4d3a29a9 100644
--- a/package/go/go.mk
+++ b/package/go/go.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-GO_VERSION = 1.19.1
+GO_VERSION = 1.19.2
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz